p PatchFirst

CVE-2026-34236

CVE-2026-34236 · Auth0 PHP SDK Insufficient Entropy in Cookie Encryption

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. From version 8.0.0 to before version 8.19.0, in applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. This issue has been patched in version 8.19.0.

CVSS 8.2 · Hoch · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: php

Betroffene Produkte und Versionen

  • auth0-php

    Softwareversionen
    • >= 8.0.0, < 8.19.0: Betroffen

    Keine Korrektur veröffentlicht

  • auth0/auth0-php Packagist

    Softwareversionen
    • 8.0.0
    • 8.0.1
    • 8.0.2
    • 8.0.3
    • 8.0.4
    • 8.0.5
    • 8.0.6
    • 8.1.0
    • 8.10.0
    • 8.11.0
    • 8.11.1
    • 8.12.0
    • 8.13.0
    • 8.14.0
    • 8.15.0
    • 8.16.0
    • 8.17.0
    • 8.18.0
    • 8.2.0
    • 8.2.1
    • 8.3.0
    • 8.3.1
    • 8.3.2
    • 8.3.3
    • 8.3.4
    • 8.3.5
    • 8.3.6
    • 8.3.7
    • 8.3.8
    • 8.4.0
    • 8.5.0
    • 8.6.0
    • 8.7.0
    • 8.7.1
    • 8.8.0
    • 8.9.0
    • 8.9.1
    • 8.9.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 8.0.0, < 8.19.0

    Auf 8.19.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →