p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in auth0/auth0-php

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für auth0/auth0-php: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 5

  1. CVE-2026-34236

    Hoch · CVSS 8.2EPSS 0,22%Korrektur verfügbar

    Auth0 PHP SDK Insufficient Entropy in Cookie Encryption

    Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. From version 8.0.0 to before version 8.19.0, in applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. This issue has been patched in version 8.19.0.

    • Auf 8.19.0 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2025-68129

    Mittel · CVSS 6.8EPSS 0,43%Korrektur verfügbar

    Auth0-PHP SDK has Improper Audience Validation

    Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens. Projects are affected if they use Auth0-PHP SDK versions between v8.0.0 and v8.17.0, or applications using the following SDKs that rely on the Auth0-PHP SDK versions between v8.0.0 and v8.17.0: Auth0/symfony versions between 5.0.0 and 5.5.0, Auth0/laravel-auth0 versions between 7.0.0 and 7.19.0, and/or Auth0/wordpress plugin versions between 5.0.0-BETA0 and 5.4.0. Auth0/Auth0-PH

    • Auf 8.18.0 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2025-58769

    Niedrig · CVSS 3.3EPSS 0,35%Korrektur verfügbar

    auth0-PHP: Improper File Type Handling in Bulk User Import

    auth0-PHP is an SDK for Auth0 Authentication and Management APIs. In versions 3.3.0 through 8.16.0, the Bulk User Import endpoint in applications built with the SDK does not validate the file-path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs. The vulnerability affects any application that either directly uses the Auth0-PHP SDK (versions 3.3.0–8.16.0) or indirectly relies on those versions through the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs. This issue is fixed in version 8.17.0.

    • Auf 8.17.0 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2025-48951

    Kritisch · CVSS 9.3EPSS 0,75%Korrektur verfügbar

    Auth0-PHP SDK Deserialization of Untrusted Data vulnerability

    Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. Versions 8.0.0-BETA3 prior to 8.3.1 contain a vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data. Applications using the Auth0-PHP SDK are affected, as are applications using the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs, because those SDKsrely on the Auth0-PHP SDK versions from 8.0.0-BETA3 until 8.14.0. Version 8.3.1 contains a patch for the issue.

    • Auf 8.3.1 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2025-47275

    Kritisch · CVSS 9.1EPSS 0,54%Korrektur verfügbar

    Brute Force Authentication Tags of CookieStore Sessions in Auth0-PHP SDK

    Auth0-PHP provides the PHP SDK for Auth0 Authentication and Management APIs. Starting in version 8.0.0-BETA1 and prior to version 8.14.0, session cookies of applications using the Auth0-PHP SDK configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access. Certain pre-conditions are required to be vulnerable to this issue: Applications using the Auth0-PHP SDK, or the Auth0/symfony, Auth0/laravel-auth0, and Auth0/wordpress SDKs that rely on the Auth0-PHP SDK; and session storage configured with CookieStore. Upgrade Auth0/Auth0-PHP to v8.14.0 to receive a patch. As an additional precautio

    • Auf 8.14.0 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →