CVE-2026-40864
CVE-2026-40864 · JupyterHub: Cross-origin form POSTs bypass XSRF
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
JupyterHub is software that allows users to create a multi-user server for Jupyter notebooks. In versions 4.1.0 through 5.4.4, XSRF protection (updated in 4.1.0) inappropriately treated requests with Sec-Fetch-Mode: no-cors as same-origin requests, bypassing XSRF checks. The JSON API is not affected, only HTTP form endpoints, such as /hub/spawn and /hub/accept-share, meaning attackers could trigger server spawn (but not access the server) and if the attacker is a JupyterHub user permitted to share access to their server, cause a user to accept a share and have access to the attacker's server. This issue has been fixed in version 5.4.5. If developers are unable to immediately upgrade, they can temporarily mitigate this issue by dropping requests to JupyterHub with Sec-Fetch-Mode: no-cors if they are using a reverse proxy.
CVSS 5.4 · Mittel · EPSS 0,1% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
jupyterhub
- Softwareversionen
- >= 4.1.0, < 5.4.5: Betroffen
Keine Korrektur veröffentlicht
jupyterhub Debian:13
- Softwareversionen
- 5.2.1+ds1-4
- 5.2.1+ds1-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyterhub Debian:14
- Softwareversionen
- 5.2.1+ds1-4
- 5.2.1+ds1-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyterhub PyPI
- Softwareversionen
- 4.1.0
- 4.1.1
- 4.1.2
- 4.1.3
- 4.1.4
- 4.1.5
- 4.1.6
- 5.0.0
- 5.0.0b1
- 5.0.0b2
- 5.1.0
- 5.2.0
- 5.2.1
- 5.3.0
- 5.3.0rc0
- 5.4.0
- 5.4.1
- 5.4.2
- 5.4.3
- 5.4.4
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 4.1.0, < 5.4.5
Auf 5.4.5 aktualisieren
jupyterhub Ubuntu:22.04:LTS
- Softwareversionen
- 2.0.0+ds1-1
- 2.0.0+ds1-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyterhub Ubuntu:24.04:LTS
- Softwareversionen
- 3.0.0+ds1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyterhub Ubuntu:25.10
- Softwareversionen
- 5.2.1+ds1-2
- 5.2.1+ds1-3
- 5.2.1+ds1-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyterhub Ubuntu:26.10
- Softwareversionen
- 5.2.1+ds1-4
- 5.2.1+ds1-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyterhub Ubuntu:26.04:LTS
- Softwareversionen
- 5.2.1+ds1-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht