CVE-2026-41140
CVE-2026-41140 · Poetry: Path traversal in tar extraction on Python 3.10.0 - 3.10.12 and 3.11.0 - 3.11.4
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Poetry is a dependency manager for Python. Prior to 2.3.4, the extractall() function in src/poetry/utils/helpers.py:410-426 extracts sdist tarballs without path traversal protection on Python versions where tarfile.data_filter is unavailable. Considering only Python versions which are still supported by Poetry, these are 3.10.0 - 3.10.12 and 3.11.0 - 3.11.4. This vulnerability is fixed in 2.3.4.
CVSS 0.6 · Niedrig · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
poetry
- Softwareversionen
- < 2.3.4: Betroffen
Keine Korrektur veröffentlicht
poetry Debian:12
- Softwareversionen
- 1.3.2+dfsg-3
- 1.3.2+dfsg-4
- 1.3.2+dfsg-5
- 1.5.1+dfsg-1
- 1.5.1+dfsg-2
- 1.5.1+dfsg-3
- 1.5.1+dfsg-4
- 1.6.1+dfsg-1
- 1.6.1+dfsg-2
- 1.7.1+dfsg-1
- 1.8.0.dev0~git20240220.cff4d7d5+dfsg-1
- 1.8.0.dev0~git20240220.cff4d7d5+dfsg-2
- 1.8.2+dfsg-1
- 1.8.3+dfsg-1
- 1.8.3+dfsg-2
- 1.8.3+dfsg-3
- 1.8.3+dfsg-4
- 2.0.1+dfsg-1
- 2.1.1+dfsg-1
- 2.1.1+dfsg-2
- 2.1.1+dfsg-3
- 2.1.2+dfsg-1
- 2.2.1+dfsg-1
- 2.2.1+dfsg-2
- 2.2.1+dfsg-3
- 2.3.2+dfsg-1
- 2.3.2+dfsg-2
- 2.3.2+dfsg-3
- 2.3.4-0.1
- 2.3.4-1
- 2.3.4-2
- 2.3.4-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
poetry Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.1.2+dfsg-1
Auf 2.1.2+dfsg-1 aktualisieren
poetry Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.1.2+dfsg-1
Auf 2.1.2+dfsg-1 aktualisieren
poetry PyPI
- Softwareversionen
- 0.1.0
- 0.10.0
- 0.10.0a0
- 0.10.0a1
- 0.10.0a2
- 0.10.0a3
- 0.10.1
- 0.10.2
- 0.10.3
- 0.11.0
- 0.11.0a0
- 0.11.0a1
- 0.11.0a2
- 0.11.0a3
- 0.11.0a4
- 0.11.1
- 0.11.2
- 0.11.3
- 0.11.4
- 0.11.5
- 0.12.0
- 0.12.0a0
- 0.12.0a1
- 0.12.0a2
- 0.12.0a3
- 0.12.0a4
- 0.12.0a5
- 0.12.1
- 0.12.10
- 0.12.11
- 0.12.12
- 0.12.13
- 0.12.14
- 0.12.15
- 0.12.16
- 0.12.17
- 0.12.2
- 0.12.3
- 0.12.4
- 0.12.5
- 0.12.6
- 0.12.7
- 0.12.8
- 0.12.9
- 0.2.0
- 0.3.0
- 0.4.0
- 0.4.0.post1
- 0.4.1
- 0.4.2
- 0.5.0
- 0.5.0b1
- 0.5.0b2
- 0.6.0
- 0.6.1
- 0.6.2
- 0.6.3
- 0.6.3b1
- 0.6.3b2
- 0.6.3b3
- 0.6.3b4
- 0.6.3b5
- 0.6.3b6
- 0.6.3b7
- 0.6.4
- 0.6.4b1
- 0.6.5
- 0.7.0
- 0.7.0b1
- 0.7.0b2
- 0.7.0b3
- 0.7.0b4
- 0.7.1
- 0.8.0
- 0.8.0a0
- 0.8.0a1
- 0.8.0a2
- 0.8.0a3
- 0.8.0a4
- 0.8.1
- 0.8.1a0
- 0.8.2
- 0.8.3
- 0.8.4
- 0.8.5
- 0.8.5a0
- 0.8.6
- 0.9.0
- 0.9.0a0
- 0.9.0a1
- 0.9.0a2
- 0.9.0a3
- 0.9.1
- 1.0.0
- 1.0.0a0
- 1.0.0a1
- 1.0.0a2
- 1.0.0a3
- 1.0.0a4
- 1.0.0a5
- 1.0.0b1
- 1.0.0b2
- 1.0.0b3
- 1.0.0b4
- 1.0.0b5
- 1.0.0b6
- 1.0.0b7
- 1.0.0b8
- 1.0.0b9
- 1.0.1
- 1.0.10
- 1.0.2
- 1.0.3
- 1.0.4
- 1.0.5
- 1.0.6
- 1.0.7
- 1.0.8
- 1.0.9
- 1.1.0
- 1.1.0a1
- 1.1.0a2
- 1.1.0a3
- 1.1.0b1
- 1.1.0b2
- 1.1.0b3
- 1.1.0b4
- 1.1.0rc1
- 1.1.1
- 1.1.10
- 1.1.11
- 1.1.12
- 1.1.13
- 1.1.14
- 1.1.15
- 1.1.2
- 1.1.3
- 1.1.4
- 1.1.5
- 1.1.6
- 1.1.7
- 1.1.8
- 1.1.9
- 1.2.0
- 1.2.0a1
- 1.2.0a2
- 1.2.0b1
- 1.2.0b2
- 1.2.0b3
- 1.2.0rc1
- 1.2.0rc2
- 1.2.1
- 1.2.2
- 1.3.0
- 1.3.1
- 1.3.2
- 1.4.0
- 1.4.1
- 1.4.2
- 1.5.0
- 1.5.1
- 1.6.0
- 1.6.1
- 1.7.0
- 1.7.1
- 1.8.0
- 1.8.1
- 1.8.2
- 1.8.3
- 1.8.4
- 1.8.5
- 2.0.0
- 2.0.1
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.3.4
Auf 2.3.4 aktualisieren
poetry Ubuntu:22.04:LTS
- Softwareversionen
- 1.1.11+dfsg-3
- 1.1.12+dfsg-1
- 1.1.12+dfsg-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
poetry Ubuntu:24.04:LTS
- Softwareversionen
- 1.6.1+dfsg-2
- 1.7.1+dfsg-1
- 1.8.2+dfsg-1ubuntu2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
poetry Ubuntu:25.10
- Softwareversionen
- 2.1.1+dfsg-3
- 2.1.2+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
poetry Ubuntu:26.10
- Softwareversionen
- 2.3.2+dfsg-3
- 2.3.4-0.1
- 2.3.4-1
- 2.3.4-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
poetry Ubuntu:26.04:LTS
- Softwareversionen
- 2.1.2+dfsg-1
- 2.3.2+dfsg-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/python-poetry/poetry/security/advisories/GHSA-73h3-mf4w-8647
- https://access.redhat.com/security/cve/CVE-2026-41140
- https://bugzilla.redhat.com/show_bug.cgi?id=2461604
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-41140.json
- https://access.redhat.com/errata/RHSA-2026:24866
- https://nvd.nist.gov/vuln/detail/CVE-2026-41140