p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in poetry

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für poetry: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 5

  1. CVE-2026-41140

    Niedrig · CVSS 0.6EPSS 0,29%Korrektur verfügbar

    Poetry: Path traversal in tar extraction on Python 3.10.0 - 3.10.12 and 3.11.0 - 3.11.4

    Poetry is a dependency manager for Python. Prior to 2.3.4, the extractall() function in src/poetry/utils/helpers.py:410-426 extracts sdist tarballs without path traversal protection on Python versions where tarfile.data_filter is unavailable. Considering only Python versions which are still supported by Poetry, these are 3.10.0 - 3.10.12 and 3.11.0 - 3.11.4. This vulnerability is fixed in 2.3.4.

    • Auf 2.3.4 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2026-34591

    Hoch · CVSS 7.1EPSS 0,49%Korrektur verfügbar

    Poetry Has Wheel Path Traversal Which Can Lead to Arbitrary File Write

    Poetry is a dependency manager for Python. From version 1.4.0 to before version 2.3.3, a crafted wheel can contain ../ paths that Poetry writes to disk without containment checks, allowing arbitrary file write with the privileges of the Poetry process. It is reachable from untrusted package artifacts during normal install flows. (Normally, installing a malicious wheel is not sufficient for execution of malicious code. Malicious code will only be executed after installation if the malicious package is imported or invoked by the user.). This issue has been patched in version 2.3.3.

    • Auf 2.3.3 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2022-36069

    Hoch · CVSS 7.3EPSS 1,32%Korrektur verfügbar

    Poetry Argument Injection vulnerability can lead to local Code Execution

    Poetry is a dependency manager for Python. When handling dependencies that come from a Git repository instead of a registry, Poetry uses various commands, such as `git clone`. These commands are constructed using user input (e.g. the repository URL). When building the commands, Poetry correctly avoids Command Injection vulnerabilities by passing an array of arguments instead of a command string. However, there is the possibility that a user input starts with a dash (`-`) and is therefore treated as an optional argument instead of a positional one. This can lead to Code Execution because some of the commands have options that can be leveraged

    • Auf 1.1.9 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2022-36070

    Hoch · CVSS 7.3EPSS 0,36%Korrektur verfügbar

    Poetry's Untrusted Search Path can lead to Local Code Execution on Windows

    Poetry is a dependency manager for Python. To handle dependencies that come from a Git repository, Poetry executes various commands, e.g. `git config`. These commands are being executed using the executable’s name and not its absolute path. This can lead to the execution of untrusted code due to the way Windows resolves executable names to paths. Unlike Linux-based operating systems, Windows searches for the executable in the current directory first and looks in the paths that are defined in the `PATH` environment variable afterward. This vulnerability can lead to Arbitrary Code Execution, which would lead to the takeover of the system. If a

    • Auf 1.1.9 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2022-26184

    Kritisch · CVSS 9.8EPSS 1,85%Korrektur verfügbar

    CVE-2022-26184

    Poetry v1.1.9 and below was discovered to contain an untrusted search path which causes the application to behave in unexpected ways when users execute Poetry commands in a directory containing malicious content. This vulnerability occurs when the application is ran on Windows OS.

    • Auf 1.1.9 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →