p PatchFirst

CVE-2026-41523

CVE-2026-41523 · vLLM: Security Check Bypass via assert Statement in Activation Function Loading Allows Arbitrary Code Execution

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.22.0, an assert-based security check in vLLM's activation function loading allows any unauthenticated attacker to achieve arbitrary code execution on the server by publishing a malicious HuggingFace model, when vLLM runs in Python optimized mode (python -O or PYTHONOPTIMIZE=1). This vulnerability is fixed in 0.22.0.

CVSS 7.5 · Hoch · EPSS 0,9% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • vllm

    Softwareversionen
    • < 0.22.0: Betroffen

    Keine Korrektur veröffentlicht

  • vllm PyPI

    Softwareversionen
    • 0.0.1
    • 0.1.0
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.1.4
    • 0.1.5
    • 0.1.6
    • 0.1.7
    • 0.10.0
    • 0.10.1
    • 0.10.1.1
    • 0.10.2
    • 0.11.0
    • 0.11.1
    • 0.11.2
    • 0.12.0
    • 0.13.0
    • 0.14.0
    • 0.14.1
    • 0.15.0
    • 0.15.1
    • 0.16.0
    • 0.17.0
    • 0.17.1
    • 0.18.0
    • 0.18.1
    • 0.19.0
    • 0.19.1
    • 0.2.0
    • 0.2.1
    • 0.2.1.post1
    • 0.2.2
    • 0.2.3
    • 0.2.4
    • 0.2.5
    • 0.2.6
    • 0.2.7
    • 0.20.0
    • 0.20.1
    • 0.20.2
    • 0.21.0
    • 0.3.0
    • 0.3.1
    • 0.3.2
    • 0.3.3
    • 0.4.0
    • 0.4.0.post1
    • 0.4.1
    • 0.4.2
    • 0.4.3
    • 0.5.0
    • 0.5.0.post1
    • 0.5.1
    • 0.5.2
    • 0.5.3
    • 0.5.3.post1
    • 0.5.4
    • 0.5.5
    • 0.6.0
    • 0.6.1
    • 0.6.1.post1
    • 0.6.1.post2
    • 0.6.2
    • 0.6.3
    • 0.6.3.post1
    • 0.6.4
    • 0.6.4.post1
    • 0.6.5
    • 0.6.6
    • 0.6.6.post1
    • 0.7.0
    • 0.7.1
    • 0.7.2
    • 0.7.3
    • 0.8.0
    • 0.8.1
    • 0.8.2
    • 0.8.3
    • 0.8.4
    • 0.8.5
    • 0.8.5.post1
    • 0.9.0
    • 0.9.0.1
    • 0.9.1
    • 0.9.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.22.0

    Auf 0.22.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →