p PatchFirst

CVE-2026-41887

CVE-2026-41887 · Flarum: Path traversal in LESS parser via theme color settings (incomplete fix for CVE-2023-27577)

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Flarum is open-source forum software. Prior to versions 1.8.16 and 2.0.0-rc.1, Flarum's patch for CVE-2023-27577 restricted the @import and data-uri() LESS features in the custom_less setting, but the same restriction was never applied to other settings registered as LESS config variables (for example theme_primary_color and theme_secondary_color, as well as any key registered via Extend\Settings::registerLessConfigVar()). Those values are interpolated verbatim into the LESS source at compile time, allowing an authenticated administrator to craft a theme-color value that injects an arbitrary @import directive into the compiled forum.css. Because the underlying LESS parser honours @import (inline) '<path>', an attacker can read arbitrary files reachable by the PHP process (local file inclusion) or trigger outbound HTTP(S) requests (server-side request forgery). This issue has been patched in versions 1.8.16 and 2.0.0-rc.1.

CVSS 4.9 · Mittel · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: php

Betroffene Produkte und Versionen

  • framework

    Softwareversionen
    • < 1.8.16: Betroffen
    • >= 2.0.0-beta.1, < 2.0.0-rc.1: Betroffen

    Keine Korrektur veröffentlicht

  • flarum/core Packagist

    Softwareversionen
    • v0.1.0-beta
    • v0.1.0-beta.10
    • v0.1.0-beta.11
    • v0.1.0-beta.11.1
    • v0.1.0-beta.12
    • v0.1.0-beta.13
    • v0.1.0-beta.14
    • v0.1.0-beta.14.1
    • v0.1.0-beta.15
    • v0.1.0-beta.16
    • v0.1.0-beta.2
    • v0.1.0-beta.3
    • v0.1.0-beta.4
    • v0.1.0-beta.5
    • v0.1.0-beta.6
    • v0.1.0-beta.7
    • v0.1.0-beta.7.1
    • v0.1.0-beta.7.2
    • v0.1.0-beta.8
    • v0.1.0-beta.8.1
    • v0.1.0-beta.8.2
    • v0.1.0-beta.9
    • v1.0.0
    • v1.0.1
    • v1.0.2
    • v1.0.3
    • v1.0.4
    • v1.1.0
    • v1.1.1
    • v1.2.0
    • v1.2.1
    • v1.3.0
    • v1.3.1
    • v1.4.0
    • v1.4.1
    • v1.5.0
    • v1.6.0
    • v1.6.1
    • v1.6.2
    • v1.6.3
    • v1.7.0
    • v1.7.1
    • v1.7.2
    • v1.8.0
    • v1.8.1
    • v1.8.10
    • v1.8.11
    • v1.8.12
    • v1.8.13
    • v1.8.14
    • v1.8.15
    • v1.8.2
    • v1.8.3
    • v1.8.4
    • v1.8.5
    • v1.8.6
    • v1.8.7
    • v1.8.8
    • v1.8.9
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.8.16

    Auf 1.8.16 aktualisieren

  • flarum/core Packagist

    Softwareversionen
    • v2.0.0-beta.1
    • v2.0.0-beta.2
    • v2.0.0-beta.3
    • v2.0.0-beta.4
    • v2.0.0-beta.5
    • v2.0.0-beta.6
    • v2.0.0-beta.7
    • v2.0.0-beta.8
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.0.0-beta.1, < 2.0.0-rc.1

    Auf 2.0.0-rc.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →