CVE-2026-41887
CVE-2026-41887 · Flarum: Path traversal in LESS parser via theme color settings (incomplete fix for CVE-2023-27577)
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Flarum is open-source forum software. Prior to versions 1.8.16 and 2.0.0-rc.1, Flarum's patch for CVE-2023-27577 restricted the @import and data-uri() LESS features in the custom_less setting, but the same restriction was never applied to other settings registered as LESS config variables (for example theme_primary_color and theme_secondary_color, as well as any key registered via Extend\Settings::registerLessConfigVar()). Those values are interpolated verbatim into the LESS source at compile time, allowing an authenticated administrator to craft a theme-color value that injects an arbitrary @import directive into the compiled forum.css. Because the underlying LESS parser honours @import (inline) '<path>', an attacker can read arbitrary files reachable by the PHP process (local file inclusion) or trigger outbound HTTP(S) requests (server-side request forgery). This issue has been patched in versions 1.8.16 and 2.0.0-rc.1.
CVSS 4.9 · Medium · EPSS 0.5% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
framework
- Versions
- < 1.8.16: Affected
- >= 2.0.0-beta.1, < 2.0.0-rc.1: Affected
No fix published
flarum/core Packagist
- Versions
- v0.1.0-beta
- v0.1.0-beta.10
- v0.1.0-beta.11
- v0.1.0-beta.11.1
- v0.1.0-beta.12
- v0.1.0-beta.13
- v0.1.0-beta.14
- v0.1.0-beta.14.1
- v0.1.0-beta.15
- v0.1.0-beta.16
- v0.1.0-beta.2
- v0.1.0-beta.3
- v0.1.0-beta.4
- v0.1.0-beta.5
- v0.1.0-beta.6
- v0.1.0-beta.7
- v0.1.0-beta.7.1
- v0.1.0-beta.7.2
- v0.1.0-beta.8
- v0.1.0-beta.8.1
- v0.1.0-beta.8.2
- v0.1.0-beta.9
- v1.0.0
- v1.0.1
- v1.0.2
- v1.0.3
- v1.0.4
- v1.1.0
- v1.1.1
- v1.2.0
- v1.2.1
- v1.3.0
- v1.3.1
- v1.4.0
- v1.4.1
- v1.5.0
- v1.6.0
- v1.6.1
- v1.6.2
- v1.6.3
- v1.7.0
- v1.7.1
- v1.7.2
- v1.8.0
- v1.8.1
- v1.8.10
- v1.8.11
- v1.8.12
- v1.8.13
- v1.8.14
- v1.8.15
- v1.8.2
- v1.8.3
- v1.8.4
- v1.8.5
- v1.8.6
- v1.8.7
- v1.8.8
- v1.8.9
- Affected ranges
- ECOSYSTEM: < 1.8.16
Update to 1.8.16
flarum/core Packagist
- Versions
- v2.0.0-beta.1
- v2.0.0-beta.2
- v2.0.0-beta.3
- v2.0.0-beta.4
- v2.0.0-beta.5
- v2.0.0-beta.6
- v2.0.0-beta.7
- v2.0.0-beta.8
- Affected ranges
- ECOSYSTEM: ≥ 2.0.0-beta.1, < 2.0.0-rc.1
Update to 2.0.0-rc.1
Original sources
- https://github.com/flarum/framework/security/advisories/GHSA-xjvc-pw2r-6878
- https://github.com/flarum/framework/commit/2d90a1f19f0e46f8c7e1b07c48ba74b5e38f8410
- https://github.com/flarum/framework/releases/tag/v1.8.16
- https://github.com/flarum/framework/releases/tag/v2.0.0-rc.1
- https://nvd.nist.gov/vuln/detail/CVE-2026-41887