CVE-2026-48125
CVE-2026-48125 · UAParser.js: Unbounded `Sec-CH-UA-Model` parsing can trigger ReDoS in `withClientHints()`
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
UAParser.js is a JavaScript library to detect browsers, operating systems, CPUs, and devices from user-agent data. From 2.0.1 until 2.0.10, a regular expression denial-of-service vulnerability exists when using the Client Hints API. By sending a crafted Sec-CH-UA-Model header to an application that calls UAParser(headers).withClientHints(), an attacker can cause excessive CPU time due to catastrophic backtracking in the device regex because Client Hints values are copied without the UA_MAX_LENGTH limit used for User-Agent values. This issue is fixed in version 2.0.10.
CVSS 5.3 · Mittel · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
ua-parser-js
- Softwareversionen
- >= 2.0.1, < 2.0.10: Betroffen
Keine Korrektur veröffentlicht
node-ua-parser-js Debian:12
- Softwareversionen
- 0.8.1+ds+~0.7.36-3
- 2.0.10+ds+~cs0.3.5-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-ua-parser-js Debian:13
- Softwareversionen
- 0.8.1+ds+~0.7.36-3
- 2.0.10+ds+~cs0.3.5-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-ua-parser-js Debian:14
- Softwareversionen
- 0.8.1+ds+~0.7.36-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.0.10+ds+~cs0.3.5-1
Auf 2.0.10+ds+~cs0.3.5-1 aktualisieren
ua-parser-js npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 2.0.1, < 2.0.10
Auf 2.0.10 aktualisieren
node-ua-parser-js Ubuntu:18.04:LTS
- Softwareversionen
- 0.7.14-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-ua-parser-js Ubuntu:20.04:LTS
- Softwareversionen
- 0.7.14-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-ua-parser-js Ubuntu:22.04:LTS
- Softwareversionen
- 0.7.24+ds-1
- 0.7.24+ds-2
- 0.7.31+ds+~0.7.36-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-ua-parser-js Ubuntu:24.04:LTS
- Softwareversionen
- 0.8.1+ds+~0.7.36-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-ua-parser-js Ubuntu:26.10
- Softwareversionen
- 0.8.1+ds+~0.7.36-3
- 2.0.10+ds+~cs0.3.5-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-ua-parser-js Ubuntu:26.04:LTS
- Softwareversionen
- 0.8.1+ds+~0.7.36-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht