p PatchFirst

CVE-2026-48125

CVE-2026-48125 · UAParser.js: Unbounded `Sec-CH-UA-Model` parsing can trigger ReDoS in `withClientHints()`

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

UAParser.js is a JavaScript library to detect browsers, operating systems, CPUs, and devices from user-agent data. From 2.0.1 until 2.0.10, a regular expression denial-of-service vulnerability exists when using the Client Hints API. By sending a crafted Sec-CH-UA-Model header to an application that calls UAParser(headers).withClientHints(), an attacker can cause excessive CPU time due to catastrophic backtracking in the device regex because Client Hints values are copied without the UA_MAX_LENGTH limit used for User-Agent values. This issue is fixed in version 2.0.10.

CVSS 5.3 · Media · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • ua-parser-js

    Versiones
    • >= 2.0.1, < 2.0.10: Afectada

    Sin corrección publicada

  • node-ua-parser-js Debian:12

    Versiones
    • 0.8.1+ds+~0.7.36-3
    • 2.0.10+ds+~cs0.3.5-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ua-parser-js Debian:13

    Versiones
    • 0.8.1+ds+~0.7.36-3
    • 2.0.10+ds+~cs0.3.5-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ua-parser-js Debian:14

    Versiones
    • 0.8.1+ds+~0.7.36-3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.0.10+ds+~cs0.3.5-1

    Actualiza a 2.0.10+ds+~cs0.3.5-1

  • ua-parser-js npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 2.0.1, < 2.0.10

    Actualiza a 2.0.10

  • node-ua-parser-js Ubuntu:18.04:LTS

    Versiones
    • 0.7.14-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ua-parser-js Ubuntu:20.04:LTS

    Versiones
    • 0.7.14-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ua-parser-js Ubuntu:22.04:LTS

    Versiones
    • 0.7.24+ds-1
    • 0.7.24+ds-2
    • 0.7.31+ds+~0.7.36-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ua-parser-js Ubuntu:24.04:LTS

    Versiones
    • 0.8.1+ds+~0.7.36-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ua-parser-js Ubuntu:26.10

    Versiones
    • 0.8.1+ds+~0.7.36-3
    • 2.0.10+ds+~cs0.3.5-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ua-parser-js Ubuntu:26.04:LTS

    Versiones
    • 0.8.1+ds+~0.7.36-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →