p PatchFirst

CVE-2026-48523

CVE-2026-48523 · PyJWT: Algorithm allow-list bypass when decoding with `PyJWK` / `PyJWKClient` keys

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

PyJWT is a JSON Web Token implementation in Python. From 2.9.0 to 2.12.1, there is a verifier-side algorithm allow-list bypass when jwt.decode() or jwt.decode_complete() are called with a PyJWK key. The token header alg is checked against the caller-supplied algorithms allow-list, but signature verification is performed with the algorithm bound to the PyJWK object instead of the header algorithm. An attacker who controls a registered JWK/JWKS private key can sign with a disallowed algorithm, advertise an allowed algorithm in the JWT header, and still be accepted. The issue affects the documented PyJWKClient.get_signing_key_from_jwt(...) flow. This vulnerability is fixed in 2.13.0.

CVSS 5.4 · Mittel · EPSS 0,1% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • pyjwt

    Softwareversionen
    • >= 2.9.0, < 2.13.0: Betroffen

    Keine Korrektur veröffentlicht

  • pyjwt Debian:13

    Softwareversionen
    • 2.10.1-2
    • 2.10.1-2+deb13u1
    • 2.10.1-3
    • 2.10.1-4
    • 2.11.0-2
    • 2.12.1-1
    • 2.13.0-1
    • 2.14.0-1
    • 2.15.0-1
    • 2.15.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pyjwt Debian:14

    Softwareversionen
    • 2.10.1-2
    • 2.10.1-3
    • 2.10.1-4
    • 2.11.0-2
    • 2.12.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.13.0-1

    Auf 2.13.0-1 aktualisieren

  • pyjwt PyPI

    Softwareversionen
    • 2.10.0
    • 2.10.1
    • 2.11.0
    • 2.12.0
    • 2.12.1
    • 2.9.0
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.9.0, < 2.13.0

    Auf 2.13.0 aktualisieren

  • pyjwt PyPI

    Softwareversionen
    • 2.10.0
    • 2.10.1
    • 2.11.0
    • 2.12.0
    • 2.9.0
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.9.0, < 2.12.1

    Auf 2.12.1 aktualisieren

  • pyjwt Ubuntu:25.10

    Softwareversionen
    • 2.10.1-2
    • 2.10.1-2ubuntu0.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pyjwt Ubuntu:26.04:LTS

    Softwareversionen
    • 2.10.1-2
    • 2.10.1-3
    • 2.10.1-3build1
    • 2.10.1-4
    • 2.10.1-4ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.10.1-4ubuntu1.1

    Auf 2.10.1-4ubuntu1.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →