CVE-2026-48998
CVE-2026-48998 · guzzlehttp/psr7 has Host Confusion via Authority Reinterpretation
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Versions prior to 2.10.2 contain improper Host header validation when parsing raw HTTP request messages and when deriving a server request URI from server variables. An attacker can provide a malformed Host header containing URI authority delimiters, such as `[email protected]`. When the Host value is used to construct a URI, the malformed value can be reinterpreted as URI userinfo and host. This can cause the PSR-7 request URI host to differ from the original Host header value. Applications are affected if they parse attacker-controlled raw HTTP requests with `GuzzleHttp\Psr7\Message::parseRequest()` or the legacy 1.x `GuzzleHttp\Psr7\parse_request()` function, or if they build server requests from attacker-controlled server variables, then rely on the resulting URI host for routing, allow-list checks, or forwarding decisions. In affected forwarding or gateway scenarios, this may cause requests or credentials to be sent to an unintended host. The issue is patched in `2.10.2`. `1.x` is end-of-life and will not receive a patch. Some workarounds are available. Validate the `Host` header as `uri-host [ ":" port ]` before calling `Message::parseRequest()` or legacy `parse_request()` on untrusted HTTP request data, or before deriving routing and forwarding decisions from a parsed request URI. Reject Host values containing userinfo, path, query, or fragment delimiters.
CVSS 5.3 · Mittel · EPSS 0,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · php
Betroffene Produkte und Versionen
psr7
- Softwareversionen
- < 2.10.2: Betroffen
Keine Korrektur veröffentlicht
php-guzzlehttp-psr7 Debian:12
- Softwareversionen
- 2.4.5-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.4.5-1+deb12u1
Auf 2.4.5-1+deb12u1 aktualisieren
php-guzzlehttp-psr7 Debian:13
- Softwareversionen
- 2.7.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.7.1-1+deb13u1
Auf 2.7.1-1+deb13u1 aktualisieren
php-guzzlehttp-psr7 Debian:14
- Softwareversionen
- 2.7.1-1
- 2.8.0-1
- 2.8.0-2
- 2.9.0-1
- 2.9.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.10.3-1
Auf 2.10.3-1 aktualisieren
guzzlehttp/psr7 Packagist
- Softwareversionen
- 1.0.0
- 1.1.0
- 1.2.0
- 1.2.1
- 1.2.2
- 1.2.3
- 1.3.0
- 1.3.1
- 1.4.0
- 1.4.1
- 1.4.2
- 1.5.0
- 1.5.1
- 1.5.2
- 1.6.0
- 1.6.1
- 1.7.0
- 1.8.0
- 1.8.1
- 1.8.2
- 1.8.3
- 1.8.4
- 1.8.5
- 1.9.0
- 1.9.1
- 2.0.0
- 2.0.0-beta1
- 2.0.0-rc1
- 2.1.0
- 2.1.1
- 2.1.2
- 2.10.0
- 2.10.1
- 2.2.0
- 2.2.1
- 2.2.2
- 2.3.0
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.4.5
- 2.5.0
- 2.5.1
- 2.6.0
- 2.6.1
- 2.6.2
- 2.6.3
- 2.7.0
- 2.7.1
- 2.8.0
- 2.8.1
- 2.9.0
- 2.9.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.10.2
Auf 2.10.2 aktualisieren
php-guzzlehttp-psr7 Ubuntu:16.04:LTS
- Softwareversionen
- 1.1.0-1
- 1.2.0-1
- 1.2.1-1
- 1.2.2-1
- 1.2.2-1build1
- 1.2.2-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
php-guzzlehttp-psr7 Ubuntu:20.04:LTS
- Softwareversionen
- 1.4.2-0.1
- 1.4.2-0.1+deb10u2build0.20.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
php-guzzlehttp-psr7 Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 1.7.0-1
- 1.8.3-1
- 1.8.3-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
php-guzzlehttp-psr7 Ubuntu:24.04:LTS
- Softwareversionen
- 2.6.0-1
- 2.6.1-1
- 2.6.2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
php-guzzlehttp-psr7 Ubuntu:25.10
- Softwareversionen
- 2.7.0-3
- 2.7.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
php-guzzlehttp-psr7 Ubuntu:26.10
- Softwareversionen
- 2.8.0-2
- 2.9.0-2
- 2.10.3-1
- 2.12.0-1
- 2.12.1-1
- 2.12.3-1
- 2.13.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
php-guzzlehttp-psr7 Ubuntu:26.04:LTS
- Softwareversionen
- 2.7.1-1
- 2.8.0-1
- 2.8.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht