p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in guzzlehttp/psr7

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für guzzlehttp/psr7: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 6

  1. CVE-2026-59882

    Mittel · CVSS 4.2EPSS 0,32%Korrektur verfügbar

    guzzlehttp/psr7: Host Confusion via Weak URI Host Validation

    guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Prior to 2.12.3, Uri::assertValidHost() does not reject URI host components containing authority delimiters, embedded ports, or malformed IPv6 brackets, allowing Uri::getHost() to disagree with the URI authority used for security or routing decisions. This issue is fixed in version 2.12.3.

    • Auf 2.12.3 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2026-55766

    Mittel · CVSS 4.8EPSS 0,23%Korrektur verfügbar

    guzzlehttp/psr7: CRLF Injection in HTTP Start-Line Serialization

    guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Prior to 2.12.1, guzzlehttp/psr7 did not reject CR/LF characters in certain first-party HTTP start-line fields: the request method, protocol version, and response reason phrase. If an application placed attacker-controlled data into one of those fields and later serialized the PSR-7 message as raw HTTP/1.x, for example with Message::toString() or an equivalent serializer, the serialized message could contain attacker-controlled header lines. The issue can also be reached through Message::parseRequest() or Message::parseResponse() when malformed raw messages are parsed into

    • Auf 2.12.1 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2026-49214

    Mittel · CVSS 5.3EPSS 0,19%Korrektur verfügbar

    guzzlehttp/psr7 has CRLF Injection via URI Host Component

    guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Versions prior to 2.10.2 did not reject ASCII control characters, whitespace, or DEL in first-party URI host components. A vulnerable flow is: First, an application accepts a user-controlled URL. Second, the URL is used to construct a PSR-7 `Uri` or `Request`. Third, the host component contains CRLF or another header-unsafe character. Fourth, the host is copied into the PSR-7 `Host` header when no explicit `Host` header is provided. Finally, the request is serialized or sent by an HTTP client that does not independently reject the malformed host. In that flow, an attacker

    • Auf 2.10.2 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2026-48998

    Mittel · CVSS 5.3EPSS 0,2%Korrektur verfügbar

    guzzlehttp/psr7 has Host Confusion via Authority Reinterpretation

    guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Versions prior to 2.10.2 contain improper Host header validation when parsing raw HTTP request messages and when deriving a server request URI from server variables. An attacker can provide a malformed Host header containing URI authority delimiters, such as `[email protected]`. When the Host value is used to construct a URI, the malformed value can be reinterpreted as URI userinfo and host. This can cause the PSR-7 request URI host to differ from the original Host header value. Applications are affected if they parse attacker-controlled raw HTTP requests with `

    • Auf 2.10.2 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2023-29197

    Mittel · CVSS 5.3EPSS 1,22%Korrektur verfügbar

    Improper header name validation in guzzlehttp/psr7

    guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Affected versions are subject to improper header parsing. An attacker could sneak in a newline (\n) into both the header names and values. While the specification states that \r\n\r\n is used to terminate the header list, many servers in the wild will also accept \n\n. This is a follow-up to CVE-2022-24775 where the fix was incomplete. The issue has been patched in versions 1.9.1 and 2.4.5. There are no known workarounds for this vulnerability. Users are advised to upgrade.

    • Auf 1.9.1 aktualisieren
    • Auf 2.4.5 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2022-24775

    Hoch · CVSS 7.5EPSS 2,48%Korrektur verfügbar

    Improper Input Validation in guzzlehttp/psr7

    guzzlehttp/psr7 is a PSR-7 HTTP message library. Versions prior to 1.8.4 and 2.1.1 are vulnerable to improper header parsing. An attacker could sneak in a new line character and pass untrusted values. The issue is patched in 1.8.4 and 2.1.1. There are currently no known workarounds.

    • Auf 1.8.4 aktualisieren
    • Auf 2.1.1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →