p PatchFirst

CVE-2026-49214

CVE-2026-49214 · guzzlehttp/psr7 has CRLF Injection via URI Host Component

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Versions prior to 2.10.2 did not reject ASCII control characters, whitespace, or DEL in first-party URI host components. A vulnerable flow is: First, an application accepts a user-controlled URL. Second, the URL is used to construct a PSR-7 `Uri` or `Request`. Third, the host component contains CRLF or another header-unsafe character. Fourth, the host is copied into the PSR-7 `Host` header when no explicit `Host` header is provided. Finally, the request is serialized or sent by an HTTP client that does not independently reject the malformed host. In that flow, an attacker can cause the serialized request to contain additional attacker-controlled header lines. For example, a host containing `"\r\nX-Injected: yes"` can cause the generated `Host` header to span multiple HTTP header lines. Applications are affected when they use user-controlled URLs for outbound HTTP requests, URL forwarding, proxying, crawling, webhook delivery, or similar request-dispatch flows. In deployments involving HTTP/1.1 connection reuse, proxies, gateways, or load balancers, this malformed request may also contribute to request smuggling or cache poisoning, depending on how downstream components parse the request. The issue is patched in `2.10.2` and later. `1.x` is end-of-life and will not receive a patch. As a workaround, validate and reject all untrusted URI strings before constructing PSR-7 `Uri` or `Request` instances. Reject input containing ASCII control characters, whitespace, or DEL, including CRLF, tab, space, NUL, or DEL characters. Applications that forward requests should also ensure the final HTTP client or serializer rejects invalid URI and header data before writing requests to the network.

CVSS 5.3 · Mittel · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · php

Betroffene Produkte und Versionen

  • psr7

    Softwareversionen
    • < 2.10.2: Betroffen

    Keine Korrektur veröffentlicht

  • php-guzzlehttp-psr7 Debian:12

    Softwareversionen
    • 2.4.5-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.5-1+deb12u1

    Auf 2.4.5-1+deb12u1 aktualisieren

  • php-guzzlehttp-psr7 Debian:13

    Softwareversionen
    • 2.7.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.7.1-1+deb13u1

    Auf 2.7.1-1+deb13u1 aktualisieren

  • php-guzzlehttp-psr7 Debian:14

    Softwareversionen
    • 2.7.1-1
    • 2.8.0-1
    • 2.8.0-2
    • 2.9.0-1
    • 2.9.0-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.10.3-1

    Auf 2.10.3-1 aktualisieren

  • guzzlehttp/psr7 Packagist

    Softwareversionen
    • 1.0.0
    • 1.1.0
    • 1.2.0
    • 1.2.1
    • 1.2.2
    • 1.2.3
    • 1.3.0
    • 1.3.1
    • 1.4.0
    • 1.4.1
    • 1.4.2
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.6.0
    • 1.6.1
    • 1.7.0
    • 1.8.0
    • 1.8.1
    • 1.8.2
    • 1.8.3
    • 1.8.4
    • 1.8.5
    • 1.9.0
    • 1.9.1
    • 2.0.0
    • 2.0.0-beta1
    • 2.0.0-rc1
    • 2.1.0
    • 2.1.1
    • 2.1.2
    • 2.10.0
    • 2.10.1
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.3.0
    • 2.4.0
    • 2.4.1
    • 2.4.2
    • 2.4.3
    • 2.4.4
    • 2.4.5
    • 2.5.0
    • 2.5.1
    • 2.6.0
    • 2.6.1
    • 2.6.2
    • 2.6.3
    • 2.7.0
    • 2.7.1
    • 2.8.0
    • 2.8.1
    • 2.9.0
    • 2.9.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.10.2

    Auf 2.10.2 aktualisieren

  • php-guzzlehttp-psr7 Ubuntu:16.04:LTS

    Softwareversionen
    • 1.1.0-1
    • 1.2.0-1
    • 1.2.1-1
    • 1.2.2-1
    • 1.2.2-1build1
    • 1.2.2-1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • php-guzzlehttp-psr7 Ubuntu:20.04:LTS

    Softwareversionen
    • 1.4.2-0.1
    • 1.4.2-0.1+deb10u2build0.20.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • php-guzzlehttp-psr7 Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 1.7.0-1
    • 1.8.3-1
    • 1.8.3-1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • php-guzzlehttp-psr7 Ubuntu:24.04:LTS

    Softwareversionen
    • 2.6.0-1
    • 2.6.1-1
    • 2.6.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • php-guzzlehttp-psr7 Ubuntu:25.10

    Softwareversionen
    • 2.7.0-3
    • 2.7.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • php-guzzlehttp-psr7 Ubuntu:26.10

    Softwareversionen
    • 2.8.0-2
    • 2.9.0-2
    • 2.10.3-1
    • 2.12.0-1
    • 2.12.1-1
    • 2.12.3-1
    • 2.13.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • php-guzzlehttp-psr7 Ubuntu:26.04:LTS

    Softwareversionen
    • 2.7.1-1
    • 2.8.0-1
    • 2.8.0-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →