CVE-2026-54249
CVE-2026-54249 · VercelAIAdapter trusts client-controlled `providerMetadata` to construct `UploadedFile` — S3/GCS confused deputy via provider metadata injection
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Pydantic AI is a Python agent framework for building Generative AI applications. In versions 1.65.0 through 1.105.0, and 2.0.0b1 through 2.0.0b5, a client that submits message history to a Pydantic AI UI adapter (such as the Vercel AI adapter) can reference arbitrary files in the application's model-provider or cloud-storage account. While file URL parts are validated against a scheme allowlist, UploadedFile references — which point to a file by provider file ID or cloud-storage URI (e.g. s3://…, gs://…) — were forwarded without validation. Because the provider resolves an UploadedFile using the server-side identity (IAM role, service account, or provider API key) rather than the client's, an attacker can craft message history to make the server read objects from its own account or other tenants, given a referenceable identifier. Exploitation requires a valid file identifier, which is not always unguessable depending on how the application names objects. This issue has been fixed in versions 1.106.0 and 2.0.0b6.
CVSS 6.8 · Mittel · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
pydantic-ai
- Softwareversionen
- >= 1.65.0, < 1.106.0: Betroffen
- >= 2.0.0b1, < 2.0.0b6: Betroffen
Keine Korrektur veröffentlicht
pydantic-ai-slim
- Softwareversionen
- >= 2.0.0b1, < 2.0.0b6: Betroffen
- >= 1.65.0, < 1.106.0: Betroffen
Keine Korrektur veröffentlicht
pydantic-ai-slim PyPI
- Softwareversionen
- 1.100.0
- 1.101.0
- 1.102.0
- 1.103.0
- 1.104.0
- 1.105.0
- 1.65.0
- 1.66.0
- 1.67.0
- 1.68.0
- 1.69.0
- 1.70.0
- 1.71.0
- 1.72.0
- 1.73.0
- 1.74.0
- 1.75.0
- 1.76.0
- 1.77.0
- 1.78.0
- 1.79.0
- 1.80.0
- 1.81.0
- 1.82.0
- 1.83.0
- 1.84.0
- 1.84.1
- 1.85.0
- 1.85.1
- 1.86.0
- 1.86.1
- 1.87.0
- 1.88.0
- 1.89.0
- 1.89.1
- 1.90.0
- 1.91.0
- 1.92.0
- 1.93.0
- 1.94.0
- 1.95.0
- 1.95.1
- 1.96.0
- 1.96.1
- 1.97.0
- 1.98.0
- 1.99.0
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 1.65.0, < 1.106.0
Auf 1.106.0 aktualisieren
pydantic-ai-slim PyPI
- Softwareversionen
- 2.0.0b1
- 2.0.0b2
- 2.0.0b3
- 2.0.0b4
- 2.0.0b5
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.0.0b1, < 2.0.0b6
Auf 2.0.0b6 aktualisieren
pydantic-ai PyPI
- Softwareversionen
- 1.100.0
- 1.101.0
- 1.102.0
- 1.103.0
- 1.104.0
- 1.105.0
- 1.65.0
- 1.66.0
- 1.67.0
- 1.68.0
- 1.69.0
- 1.70.0
- 1.71.0
- 1.72.0
- 1.73.0
- 1.74.0
- 1.75.0
- 1.76.0
- 1.77.0
- 1.78.0
- 1.79.0
- 1.80.0
- 1.81.0
- 1.82.0
- 1.83.0
- 1.84.0
- 1.84.1
- 1.85.0
- 1.85.1
- 1.86.0
- 1.86.1
- 1.87.0
- 1.88.0
- 1.89.0
- 1.89.1
- 1.90.0
- 1.91.0
- 1.92.0
- 1.93.0
- 1.94.0
- 1.95.0
- 1.95.1
- 1.96.0
- 1.96.1
- 1.97.0
- 1.98.0
- 1.99.0
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 1.65.0, < 1.106.0
Auf 1.106.0 aktualisieren
pydantic-ai PyPI
- Softwareversionen
- 2.0.0b1
- 2.0.0b2
- 2.0.0b3
- 2.0.0b4
- 2.0.0b5
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.0.0b1, < 2.0.0b6
Auf 2.0.0b6 aktualisieren
pydantic-ai PyPI
- Softwareversionen
- 1.100.0
- 1.101.0
- 1.102.0
- 1.103.0
- 1.104.0
- 1.105.0
- 1.65.0
- 1.66.0
- 1.67.0
- 1.68.0
- 1.69.0
- 1.70.0
- 1.71.0
- 1.72.0
- 1.73.0
- 1.74.0
- 1.75.0
- 1.76.0
- 1.77.0
- 1.78.0
- 1.79.0
- 1.80.0
- 1.81.0
- 1.82.0
- 1.83.0
- 1.84.0
- 1.84.1
- 1.85.0
- 1.85.1
- 1.86.0
- 1.86.1
- 1.87.0
- 1.88.0
- 1.89.0
- 1.89.1
- 1.90.0
- 1.91.0
- 1.92.0
- 1.93.0
- 1.94.0
- 1.95.0
- 1.95.1
- 1.96.0
- 1.96.1
- 1.97.0
- 1.98.0
- 1.99.0
- 2.0.0b1
- 2.0.0b2
- 2.0.0b3
- 2.0.0b4
- 2.0.0b5
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 1.65.0, < 1.106.0 ∪ ≥ 2.0.0b1, < 2.0.0b6
Auf 1.106.0 aktualisieren; Auf 2.0.0b6 aktualisieren
pydantic-ai-slim PyPI
- Softwareversionen
- 1.100.0
- 1.101.0
- 1.102.0
- 1.103.0
- 1.104.0
- 1.105.0
- 1.65.0
- 1.66.0
- 1.67.0
- 1.68.0
- 1.69.0
- 1.70.0
- 1.71.0
- 1.72.0
- 1.73.0
- 1.74.0
- 1.75.0
- 1.76.0
- 1.77.0
- 1.78.0
- 1.79.0
- 1.80.0
- 1.81.0
- 1.82.0
- 1.83.0
- 1.84.0
- 1.84.1
- 1.85.0
- 1.85.1
- 1.86.0
- 1.86.1
- 1.87.0
- 1.88.0
- 1.89.0
- 1.89.1
- 1.90.0
- 1.91.0
- 1.92.0
- 1.93.0
- 1.94.0
- 1.95.0
- 1.95.1
- 1.96.0
- 1.96.1
- 1.97.0
- 1.98.0
- 1.99.0
- 2.0.0b1
- 2.0.0b2
- 2.0.0b3
- 2.0.0b4
- 2.0.0b5
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 1.65.0, < 1.106.0 ∪ ≥ 2.0.0b1, < 2.0.0b6
Auf 1.106.0 aktualisieren; Auf 2.0.0b6 aktualisieren