CVE-2026-59870
CVE-2026-59870 · js-yaml quadratic-complexity denial of service via YAML11_SCHEMA !!omap parsing
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
js-yaml is a JavaScript YAML parser and dumper. Prior to 3.15.1, 4.3.1, and 5.2.1, YAML11_SCHEMA support for the !!omap tag in src/tag/sequence/omap.ts uses omapTag.addItem() to perform a linear duplicate-key scan on every insertion, causing O(n^2) CPU consumption when yaml.load() parses a crafted ordered-map document. In v3 and v4, !!omap is active and exploitable by default. v5 doesn't use !!omap by default, and the chances of activating it are very low.This issue is fixed in 3.15.1, 4.3.1, and 5.2.1.
CVSS 7.5 · Hoch · EPSS 0,7% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
js-yaml
- Softwareversionen
- >= 5.0.0, < 5.2.1: Betroffen
- >= 3.0.0, < 3.15.1: Betroffen
- >= 4.0.0, < 4.3.1: Betroffen
Keine Korrektur veröffentlicht
js-yaml npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 5.0.0, < 5.2.1
Auf 5.2.1 aktualisieren
node-js-yaml Ubuntu:18.04:LTS
- Softwareversionen
- 3.9.1+dfsg-1
- 3.10.0+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-js-yaml Ubuntu:20.04:LTS
- Softwareversionen
- 3.13.1+dfsg-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-js-yaml Ubuntu:22.04:LTS
- Softwareversionen
- 3.14.1+dfsg+~3.12.6-2
- 4.1.0+dfsg+~4.0.5-4ubuntu1
- 4.1.0+dfsg+~4.0.5-5
- 4.1.0+dfsg+~4.0.5-6
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-js-yaml Ubuntu:24.04:LTS
- Softwareversionen
- 4.1.0+dfsg+~4.0.5-7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-js-yaml Ubuntu:25.10
- Softwareversionen
- 4.1.0+dfsg+~4.0.5-7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-js-yaml Ubuntu:26.10
- Softwareversionen
- 4.1.1+dfsg+~4.0.9-1
- 4.2.0+~4.0.9-1
- 4.2.0+~4.0.9-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-js-yaml Ubuntu:26.04:LTS
- Softwareversionen
- 4.1.0+dfsg+~4.0.5-7
- 4.1.1+dfsg+~4.0.9-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/nodeca/js-yaml/security/advisories/GHSA-724g-mxrg-4qvm
- https://github.com/nodeca/js-yaml/commit/22a8071ef032117bc6249c330b240ac3aa2d3ded
- https://github.com/nodeca/js-yaml/commit/39f3211a2f01b3c6982710cf21434ab7060acefe
- https://github.com/nodeca/js-yaml/commit/c3cc4b0bb9ddb9af2dd9b61e0d56f5ce7983cd4a
- https://github.com/nodeca/js-yaml/releases/tag/3.15.1
- https://github.com/nodeca/js-yaml/releases/tag/4.3.1
- https://github.com/nodeca/js-yaml/releases/tag/5.2.1
- https://nvd.nist.gov/vuln/detail/CVE-2026-59870