CVE-2026-59870
CVE-2026-59870 · js-yaml quadratic-complexity denial of service via YAML11_SCHEMA !!omap parsing
This page contains facts from public vulnerability sources. Check the original advisory before updating.
js-yaml is a JavaScript YAML parser and dumper. Prior to 3.15.1, 4.3.1, and 5.2.1, YAML11_SCHEMA support for the !!omap tag in src/tag/sequence/omap.ts uses omapTag.addItem() to perform a linear duplicate-key scan on every insertion, causing O(n^2) CPU consumption when yaml.load() parses a crafted ordered-map document. In v3 and v4, !!omap is active and exploitable by default. v5 doesn't use !!omap by default, and the chances of activating it are very low.This issue is fixed in 3.15.1, 4.3.1, and 5.2.1.
CVSS 7.5 · High · EPSS 0.7% · Fix available
- Published
- Updated
Affected products and versions
js-yaml
- Versions
- >= 5.0.0, < 5.2.1: Affected
- >= 3.0.0, < 3.15.1: Affected
- >= 4.0.0, < 4.3.1: Affected
No fix published
js-yaml npm
- Affected ranges
- SEMVER: ≥ 5.0.0, < 5.2.1
Update to 5.2.1
node-js-yaml Ubuntu:18.04:LTS
- Versions
- 3.9.1+dfsg-1
- 3.10.0+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-js-yaml Ubuntu:20.04:LTS
- Versions
- 3.13.1+dfsg-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-js-yaml Ubuntu:22.04:LTS
- Versions
- 3.14.1+dfsg+~3.12.6-2
- 4.1.0+dfsg+~4.0.5-4ubuntu1
- 4.1.0+dfsg+~4.0.5-5
- 4.1.0+dfsg+~4.0.5-6
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-js-yaml Ubuntu:24.04:LTS
- Versions
- 4.1.0+dfsg+~4.0.5-7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-js-yaml Ubuntu:25.10
- Versions
- 4.1.0+dfsg+~4.0.5-7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-js-yaml Ubuntu:26.10
- Versions
- 4.1.1+dfsg+~4.0.9-1
- 4.2.0+~4.0.9-1
- 4.2.0+~4.0.9-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-js-yaml Ubuntu:26.04:LTS
- Versions
- 4.1.0+dfsg+~4.0.5-7
- 4.1.1+dfsg+~4.0.9-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/nodeca/js-yaml/security/advisories/GHSA-724g-mxrg-4qvm
- https://github.com/nodeca/js-yaml/commit/22a8071ef032117bc6249c330b240ac3aa2d3ded
- https://github.com/nodeca/js-yaml/commit/39f3211a2f01b3c6982710cf21434ab7060acefe
- https://github.com/nodeca/js-yaml/commit/c3cc4b0bb9ddb9af2dd9b61e0d56f5ce7983cd4a
- https://github.com/nodeca/js-yaml/releases/tag/3.15.1
- https://github.com/nodeca/js-yaml/releases/tag/4.3.1
- https://github.com/nodeca/js-yaml/releases/tag/5.2.1
- https://nvd.nist.gov/vuln/detail/CVE-2026-59870