p PatchFirst

CVE-2026-63385

CVE-2026-63385 · Libevent: HTTP header handling bugs create risk of access control bypass.

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Libevent is an event notification library. Prior to 2.1.13 and 2.2.2-alpha, libevent has two HTTP parsing weaknesses in http.c. evhttp_decode_uri_internal decodes percent-encoded %00 bytes into literal NUL characters, which can cause downstream C string operations to truncate a path and bypass validation performed on a different representation. evhttp_header_is_valid_value also accepts obsolete line folding in header values containing carriage return or line feed characters, allowing a proxy and libevent to interpret headers differently and enabling header injection or access control bypass. The CRLF header acceptance is fixed in versions 2.1.13 and 2.2.2-alpha, but the reviewed patches do not clearly remediate the URI NUL-truncation condition.

CVSS 9.2 · Kritisch · EPSS 1,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • libevent

    Softwareversionen
    • >= 2.2.0-alpha, < 2.2.2-alpha: Betroffen
    • < 2.1.13: Betroffen

    Keine Korrektur veröffentlicht

  • libevent Debian:12

    Softwareversionen
    • 2.1.12-stable-8
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.1.12-stable-8+deb12u1

    Auf 2.1.12-stable-8+deb12u1 aktualisieren

  • libevent Debian:13

    Softwareversionen
    • 2.1.12-stable-10
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.1.13-stable-1~deb13u1

    Auf 2.1.13-stable-1~deb13u1 aktualisieren

  • libevent Debian:14

    Softwareversionen
    • 2.1.12-stable-10
    • 2.1.13-stable-1~deb13u1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.1.13-stable-1

    Auf 2.1.13-stable-1 aktualisieren

  • libevent Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 2.0.21-stable-1
    • 2.0.21-stable-1ubuntu1
    • 2.0.21-stable-1ubuntu1.14.04.1
    • 2.0.21-stable-1ubuntu1.14.04.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.0.21-stable-1ubuntu1.14.04.2+esm1

    Auf 2.0.21-stable-1ubuntu1.14.04.2+esm1 aktualisieren

  • libevent Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 2.0.21-stable-2
    • 2.0.21-stable-2ubuntu0.16.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.0.21-stable-2ubuntu0.16.04.1+esm1

    Auf 2.0.21-stable-2ubuntu0.16.04.1+esm1 aktualisieren

  • libevent Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 2.1.8-stable-4
    • 2.1.8-stable-4build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.1.8-stable-4ubuntu0.1~esm1

    Auf 2.1.8-stable-4ubuntu0.1~esm1 aktualisieren

  • libevent Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 2.1.8-stable-4build1
    • 2.1.11-stable-1~exp0
    • 2.1.11-stable-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.1.11-stable-1ubuntu0.1~esm1

    Auf 2.1.11-stable-1ubuntu0.1~esm1 aktualisieren

  • libevent Ubuntu:22.04:LTS

    Softwareversionen
    • 2.1.12-stable-1
    • 2.1.12-stable-1build1
    • 2.1.12-stable-1build2
    • 2.1.12-stable-1build3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.1.12-stable-1ubuntu0.1

    Auf 2.1.12-stable-1ubuntu0.1 aktualisieren

  • libevent Ubuntu:24.04:LTS

    Softwareversionen
    • 2.1.12-stable-9
    • 2.1.12-stable-9ubuntu2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.1.12-stable-9ubuntu2.1

    Auf 2.1.12-stable-9ubuntu2.1 aktualisieren

  • libevent Ubuntu:26.04:LTS

    Softwareversionen
    • 2.1.12-stable-10build1
    • 2.1.12-stable-10build2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.1.12-stable-10ubuntu0.1

    Auf 2.1.12-stable-10ubuntu0.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →