CVE-2026-63385
CVE-2026-63385 · Libevent: HTTP header handling bugs create risk of access control bypass.
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Libevent is an event notification library. Prior to 2.1.13 and 2.2.2-alpha, libevent has two HTTP parsing weaknesses in http.c. evhttp_decode_uri_internal decodes percent-encoded %00 bytes into literal NUL characters, which can cause downstream C string operations to truncate a path and bypass validation performed on a different representation. evhttp_header_is_valid_value also accepts obsolete line folding in header values containing carriage return or line feed characters, allowing a proxy and libevent to interpret headers differently and enabling header injection or access control bypass. The CRLF header acceptance is fixed in versions 2.1.13 and 2.2.2-alpha, but the reviewed patches do not clearly remediate the URI NUL-truncation condition.
CVSS 9.2 · Critical · EPSS 1.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
libevent
- Versions
- >= 2.2.0-alpha, < 2.2.2-alpha: Affected
- < 2.1.13: Affected
No fix published
libevent Debian:12
- Versions
- 2.1.12-stable-8
- Affected ranges
- ECOSYSTEM: < 2.1.12-stable-8+deb12u1
Update to 2.1.12-stable-8+deb12u1
libevent Debian:13
- Versions
- 2.1.12-stable-10
- Affected ranges
- ECOSYSTEM: < 2.1.13-stable-1~deb13u1
Update to 2.1.13-stable-1~deb13u1
libevent Debian:14
- Versions
- 2.1.12-stable-10
- 2.1.13-stable-1~deb13u1
- Affected ranges
- ECOSYSTEM: < 2.1.13-stable-1
Update to 2.1.13-stable-1
libevent Ubuntu:Pro:14.04:LTS
- Versions
- 2.0.21-stable-1
- 2.0.21-stable-1ubuntu1
- 2.0.21-stable-1ubuntu1.14.04.1
- 2.0.21-stable-1ubuntu1.14.04.2
- Affected ranges
- ECOSYSTEM: < 2.0.21-stable-1ubuntu1.14.04.2+esm1
Update to 2.0.21-stable-1ubuntu1.14.04.2+esm1
libevent Ubuntu:Pro:16.04:LTS
- Versions
- 2.0.21-stable-2
- 2.0.21-stable-2ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: < 2.0.21-stable-2ubuntu0.16.04.1+esm1
Update to 2.0.21-stable-2ubuntu0.16.04.1+esm1
libevent Ubuntu:Pro:18.04:LTS
- Versions
- 2.1.8-stable-4
- 2.1.8-stable-4build1
- Affected ranges
- ECOSYSTEM: < 2.1.8-stable-4ubuntu0.1~esm1
Update to 2.1.8-stable-4ubuntu0.1~esm1
libevent Ubuntu:Pro:20.04:LTS
- Versions
- 2.1.8-stable-4build1
- 2.1.11-stable-1~exp0
- 2.1.11-stable-1
- Affected ranges
- ECOSYSTEM: < 2.1.11-stable-1ubuntu0.1~esm1
Update to 2.1.11-stable-1ubuntu0.1~esm1
libevent Ubuntu:22.04:LTS
- Versions
- 2.1.12-stable-1
- 2.1.12-stable-1build1
- 2.1.12-stable-1build2
- 2.1.12-stable-1build3
- Affected ranges
- ECOSYSTEM: < 2.1.12-stable-1ubuntu0.1
Update to 2.1.12-stable-1ubuntu0.1
libevent Ubuntu:24.04:LTS
- Versions
- 2.1.12-stable-9
- 2.1.12-stable-9ubuntu2
- Affected ranges
- ECOSYSTEM: < 2.1.12-stable-9ubuntu2.1
Update to 2.1.12-stable-9ubuntu2.1
libevent Ubuntu:26.04:LTS
- Versions
- 2.1.12-stable-10build1
- 2.1.12-stable-10build2
- Affected ranges
- ECOSYSTEM: < 2.1.12-stable-10ubuntu0.1
Update to 2.1.12-stable-10ubuntu0.1
Original sources
- https://github.com/libevent/libevent/security/advisories/GHSA-jcwh-pvf2-73p2
- https://github.com/libevent/libevent/commit/758be0c0f69c1934ef9a84ab39e9f9e5fde2e6d0
- https://github.com/libevent/libevent/commit/9170dd35e64714613e8d13b290587cfc28e258e2
- https://github.com/libevent/libevent/releases/tag/release-2.1.13-stable
- https://github.com/libevent/libevent/releases/tag/release-2.2.2-alpha
- https://nvd.nist.gov/vuln/detail/CVE-2026-63385