p PatchFirst

CVE-2026-69152

CVE-2026-69152 · brace-expansion: DoS via unbounded intermediate arrays, bypassing the CVE-2026-14257 mitigation

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.18, 2.1.4, 3.0.6, and 5.0.9, expand() does not apply maxLength while constructing comma-alternative intermediate arrays or padded sequences, allowing attacker-controlled input to exhaust memory or block the event loop. The fix for CVE-2026-14257 is bypassed by the vulnerability. This issue is fixed in versions 1.1.18, 2.1.4, 3.0.6, and 5.0.9.

CVSS 7.5 · Hoch · EPSS 0,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • brace-expansion

    Softwareversionen
    • < 1.1.18: Betroffen
    • >= 2.0.0, < 2.1.4: Betroffen
    • >= 3.0.0, < 3.0.6: Betroffen
    • >= 4.0.0, < 5.0.9: Betroffen

    Keine Korrektur veröffentlicht

  • brace-expansion npm

    Betroffene Versionsbereiche
    • SEMVER: < 1.1.18

    Auf 1.1.18 aktualisieren

  • brace-expansion npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.0.0, < 2.1.4

    Auf 2.1.4 aktualisieren

  • brace-expansion npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 3.0.0, < 3.0.6

    Auf 3.0.6 aktualisieren

  • brace-expansion npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 4.0.0, < 5.0.9

    Auf 5.0.9 aktualisieren

  • node-brace-expansion Ubuntu:18.04:LTS

    Softwareversionen
    • 1.1.8-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:20.04:LTS

    Softwareversionen
    • 1.1.8-1
    • 1.1.11-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:22.04:LTS

    Softwareversionen
    • 2.0.0-1
    • 2.0.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:24.04:LTS

    Softwareversionen
    • 2.0.1-2
    • 2.0.1+~1.1.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:26.10

    Softwareversionen
    • 2.0.1+~1.1.0-2
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-brace-expansion Ubuntu:26.04:LTS

    Softwareversionen
    • 2.0.1+~1.1.0-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →