p PatchFirst

CVE-2026-69152

CVE-2026-69152 · brace-expansion: DoS via unbounded intermediate arrays, bypassing the CVE-2026-14257 mitigation

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.18, 2.1.4, 3.0.6, and 5.0.9, expand() does not apply maxLength while constructing comma-alternative intermediate arrays or padded sequences, allowing attacker-controlled input to exhaust memory or block the event loop. The fix for CVE-2026-14257 is bypassed by the vulnerability. This issue is fixed in versions 1.1.18, 2.1.4, 3.0.6, and 5.0.9.

CVSS 7.5 · High · EPSS 0.6% · Fix available

Published
Updated

Stack: system · node

Affected products and versions

  • brace-expansion

    Versions
    • < 1.1.18: Affected
    • >= 2.0.0, < 2.1.4: Affected
    • >= 3.0.0, < 3.0.6: Affected
    • >= 4.0.0, < 5.0.9: Affected

    No fix published

  • brace-expansion npm

    Affected ranges
    • SEMVER: < 1.1.18

    Update to 1.1.18

  • brace-expansion npm

    Affected ranges
    • SEMVER: ≥ 2.0.0, < 2.1.4

    Update to 2.1.4

  • brace-expansion npm

    Affected ranges
    • SEMVER: ≥ 3.0.0, < 3.0.6

    Update to 3.0.6

  • brace-expansion npm

    Affected ranges
    • SEMVER: ≥ 4.0.0, < 5.0.9

    Update to 5.0.9

  • node-brace-expansion Ubuntu:18.04:LTS

    Versions
    • 1.1.8-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • node-brace-expansion Ubuntu:20.04:LTS

    Versions
    • 1.1.8-1
    • 1.1.11-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • node-brace-expansion Ubuntu:22.04:LTS

    Versions
    • 2.0.0-1
    • 2.0.1-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • node-brace-expansion Ubuntu:24.04:LTS

    Versions
    • 2.0.1-2
    • 2.0.1+~1.1.0-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • node-brace-expansion Ubuntu:26.10

    Versions
    • 2.0.1+~1.1.0-2
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • node-brace-expansion Ubuntu:26.04:LTS

    Versions
    • 2.0.1+~1.1.0-2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →