p PatchFirst

CVE-2026-7142

CVE-2026-7142 · Wooey API Endpoint scripts.py add_or_update_script improper authorization

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A vulnerability was determined in Wooey up to 0.13.2. The impacted element is the function add_or_update_script of the file wooey/api/scripts.py of the component API Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 0.13.3rc1 and 0.14.0 is sufficient to resolve this issue. This patch is called f7846fc0c323da8325422cab32623491757f1b88. The affected component should be upgraded.

CVSS 5.3 · Mittel · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • wooey

    Softwareversionen
    • 0.13.0: Betroffen
    • 0.13.1: Betroffen
    • 0.13.2: Betroffen
    • 0.13.3rc1: Nicht betroffen
    • 0.14.0: Nicht betroffen

    Auf 0.13.3rc1 aktualisieren

  • wooey PyPI

    Softwareversionen
    • 0.0.1
    • 0.0.2
    • 0.0.3
    • 0.0.4
    • 0.10.0
    • 0.10.1
    • 0.10.dev0
    • 0.11.0
    • 0.11.0rc1
    • 0.11.0rc2
    • 0.11.0rc3
    • 0.11.1
    • 0.11.1rc2
    • 0.11.1rc3
    • 0.11.1rc4
    • 0.11.1rc5
    • 0.11.1rc6
    • 0.11.1rc7
    • 0.12.0
    • 0.12.0rc1
    • 0.12.0rc2
    • 0.12.0rc3
    • 0.13.0
    • 0.13.1
    • 0.13.2
    • 0.13.2rc1
    • 0.13.2rc2
    • 0.13.2rc3
    • 0.9.0
    • 0.9.1
    • 0.9.10
    • 0.9.11
    • 0.9.2
    • 0.9.3
    • 0.9.4
    • 0.9.5
    • 0.9.6
    • 0.9.8
    • 0.9.9
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.13.3rc1

    Auf 0.13.3rc1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →