p PatchFirst

CVE-2026-7142

CVE-2026-7142 · Wooey API Endpoint scripts.py add_or_update_script improper authorization

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A vulnerability was determined in Wooey up to 0.13.2. The impacted element is the function add_or_update_script of the file wooey/api/scripts.py of the component API Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 0.13.3rc1 and 0.14.0 is sufficient to resolve this issue. This patch is called f7846fc0c323da8325422cab32623491757f1b88. The affected component should be upgraded.

CVSS 5.3 · Medium · EPSS 0.2% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • wooey

    Versions
    • 0.13.0: Affected
    • 0.13.1: Affected
    • 0.13.2: Affected
    • 0.13.3rc1: Not affected
    • 0.14.0: Not affected

    Update to 0.13.3rc1

  • wooey PyPI

    Versions
    • 0.0.1
    • 0.0.2
    • 0.0.3
    • 0.0.4
    • 0.10.0
    • 0.10.1
    • 0.10.dev0
    • 0.11.0
    • 0.11.0rc1
    • 0.11.0rc2
    • 0.11.0rc3
    • 0.11.1
    • 0.11.1rc2
    • 0.11.1rc3
    • 0.11.1rc4
    • 0.11.1rc5
    • 0.11.1rc6
    • 0.11.1rc7
    • 0.12.0
    • 0.12.0rc1
    • 0.12.0rc2
    • 0.12.0rc3
    • 0.13.0
    • 0.13.1
    • 0.13.2
    • 0.13.2rc1
    • 0.13.2rc2
    • 0.13.2rc3
    • 0.9.0
    • 0.9.1
    • 0.9.10
    • 0.9.11
    • 0.9.2
    • 0.9.3
    • 0.9.4
    • 0.9.5
    • 0.9.6
    • 0.9.8
    • 0.9.9
    Affected ranges
    • ECOSYSTEM: < 0.13.3rc1

    Update to 0.13.3rc1

Original sources

Check your server →