p PatchFirst

CVE-2026-73416

CVE-2026-73416 · jupyterlab: PyPI extension blocklist package-name canonicalization bypass

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

jupyterlab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 4.5.0 until 4.5.10 and 4.6.2, in jupyterlab/extensions/manager.py and jupyterlab/extensions/pypi.py, JupyterLab's PyPI extension manager enforces blocked_extensions_uris by comparing requested install names to blocklist entries with custom normalization that is weaker than PyPI package-name canonicalization. An authenticated user can request a PyPI-equivalent spelling such as JupyterLab.Git for a blocklisted package such as jupyterlab-git, and JupyterLab accepts the install request even though pip resolves the variant to the same package. Security impact requires an allowlist or blocklist intended to restrict package installation, the PyPI Extension Manager, and kernels and terminals that are disabled or delegated to remote hosts. The bypass lets an authenticated user install a prohibited extension, defeat integrity restrictions, and affect availability without gaining new read access. This issue is fixed in versions 4.5.10 and 4.6.2.

CVSS 6.1 · Mittel · EPSS 0,7% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • jupyterlab

    Softwareversionen
    • >= 4.5.0, < 4.5.10: Betroffen
    • >= 4.6.0, < 4.6.2: Betroffen

    Keine Korrektur veröffentlicht

  • jupyterlab Debian:13

    Softwareversionen
    • 4.0.11+ds1+~cs11.25.27-7
    • 4.0.11+ds1+~cs11.25.27-8
    • 4.0.11+ds1+~cs11.25.27-9
    • 4.0.11+ds2+~cs11.25.27-1
    • 4.0.11+ds2+~cs11.25.27-3
    • 4.0.11+ds3+~cs11.25.27-1
    • 4.0.11+ds4+~cs11.25.27-1
    • 4.0.11+ds4+~cs11.25.27-2
    • 4.0.11+ds4+~cs11.25.27-3
    • 4.0.11+ds4+~cs11.25.27-4
    • 4.0.11+ds5+~cs11.25.27-1
    • 4.0.13+ds1+~2.0.1+~cs1.4.4-1
    • 4.1.3+ds1+~2.0.1+~0.15.3+~cs1.4.4-1
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-1
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-2
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-3
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-4
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-5
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-6
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-7
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-8
    • 4.4.1+ds1+~3.0.5+~0.16.6+~cs1.4.4-1
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-1
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-2
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-5
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-6
    • 4.4.8+ds1+~3.1.0+~0.16.6+~cs1.4.4-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • jupyterlab Debian:14

    Softwareversionen
    • 4.0.11+ds1+~cs11.25.27-7
    • 4.0.11+ds1+~cs11.25.27-8
    • 4.0.11+ds1+~cs11.25.27-9
    • 4.0.11+ds2+~cs11.25.27-1
    • 4.0.11+ds2+~cs11.25.27-3
    • 4.0.11+ds3+~cs11.25.27-1
    • 4.0.11+ds4+~cs11.25.27-1
    • 4.0.11+ds4+~cs11.25.27-2
    • 4.0.11+ds4+~cs11.25.27-3
    • 4.0.11+ds4+~cs11.25.27-4
    • 4.0.11+ds5+~cs11.25.27-1
    • 4.0.13+ds1+~2.0.1+~cs1.4.4-1
    • 4.1.3+ds1+~2.0.1+~0.15.3+~cs1.4.4-1
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-1
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-2
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-3
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-4
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-5
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-6
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-7
    • 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-8
    • 4.4.1+ds1+~3.0.5+~0.16.6+~cs1.4.4-1
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-1
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-2
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3
    • 4.4.8+ds1+~3.1.0+~0.16.6+~cs1.4.4-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4

    Auf 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4 aktualisieren

  • jupyterlab PyPI

    Softwareversionen
    • 4.6.0
    • 4.6.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 4.6.0, < 4.6.2

    Auf 4.6.2 aktualisieren

  • jupyterlab PyPI

    Softwareversionen
    • 4.5.0
    • 4.5.1
    • 4.5.2
    • 4.5.3
    • 4.5.4
    • 4.5.5
    • 4.5.6
    • 4.5.7
    • 4.5.8
    • 4.5.9
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 4.5.0, < 4.5.10

    Auf 4.5.10 aktualisieren

  • jupyterlab PyPI

    Softwareversionen
    • 4.5.0
    • 4.5.1
    • 4.5.2
    • 4.5.3
    • 4.5.4
    • 4.5.5
    • 4.5.6
    • 4.5.7
    • 4.5.8
    • 4.5.9
    • 4.6.0
    • 4.6.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 4.5.0, < 4.5.10 ∪ ≥ 4.6.0, < 4.6.2

    Auf 4.5.10 aktualisieren; Auf 4.6.2 aktualisieren

  • jupyterlab Ubuntu:26.10

    Softwareversionen
    • 4.0.11+ds1+~cs11.25.27-9
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3
    • 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • jupyterlab Ubuntu:26.04:LTS

    Softwareversionen
    • 4.0.11+ds1+~cs11.25.27-7
    • 4.0.11+ds1+~cs11.25.27-8
    • 4.0.11+ds1+~cs11.25.27-9
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →