CVE-2026-73416
CVE-2026-73416 · jupyterlab: PyPI extension blocklist package-name canonicalization bypass
This page contains facts from public vulnerability sources. Check the original advisory before updating.
jupyterlab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 4.5.0 until 4.5.10 and 4.6.2, in jupyterlab/extensions/manager.py and jupyterlab/extensions/pypi.py, JupyterLab's PyPI extension manager enforces blocked_extensions_uris by comparing requested install names to blocklist entries with custom normalization that is weaker than PyPI package-name canonicalization. An authenticated user can request a PyPI-equivalent spelling such as JupyterLab.Git for a blocklisted package such as jupyterlab-git, and JupyterLab accepts the install request even though pip resolves the variant to the same package. Security impact requires an allowlist or blocklist intended to restrict package installation, the PyPI Extension Manager, and kernels and terminals that are disabled or delegated to remote hosts. The bypass lets an authenticated user install a prohibited extension, defeat integrity restrictions, and affect availability without gaining new read access. This issue is fixed in versions 4.5.10 and 4.6.2.
CVSS 6.1 · Medium · EPSS 0.7% · Fix available
- Published
- Updated
Affected products and versions
jupyterlab
- Versions
- >= 4.5.0, < 4.5.10: Affected
- >= 4.6.0, < 4.6.2: Affected
No fix published
jupyterlab Debian:13
- Versions
- 4.0.11+ds1+~cs11.25.27-7
- 4.0.11+ds1+~cs11.25.27-8
- 4.0.11+ds1+~cs11.25.27-9
- 4.0.11+ds2+~cs11.25.27-1
- 4.0.11+ds2+~cs11.25.27-3
- 4.0.11+ds3+~cs11.25.27-1
- 4.0.11+ds4+~cs11.25.27-1
- 4.0.11+ds4+~cs11.25.27-2
- 4.0.11+ds4+~cs11.25.27-3
- 4.0.11+ds4+~cs11.25.27-4
- 4.0.11+ds5+~cs11.25.27-1
- 4.0.13+ds1+~2.0.1+~cs1.4.4-1
- 4.1.3+ds1+~2.0.1+~0.15.3+~cs1.4.4-1
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-1
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-2
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-3
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-4
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-5
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-6
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-7
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-8
- 4.4.1+ds1+~3.0.5+~0.16.6+~cs1.4.4-1
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-1
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-2
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-5
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-6
- 4.4.8+ds1+~3.1.0+~0.16.6+~cs1.4.4-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jupyterlab Debian:14
- Versions
- 4.0.11+ds1+~cs11.25.27-7
- 4.0.11+ds1+~cs11.25.27-8
- 4.0.11+ds1+~cs11.25.27-9
- 4.0.11+ds2+~cs11.25.27-1
- 4.0.11+ds2+~cs11.25.27-3
- 4.0.11+ds3+~cs11.25.27-1
- 4.0.11+ds4+~cs11.25.27-1
- 4.0.11+ds4+~cs11.25.27-2
- 4.0.11+ds4+~cs11.25.27-3
- 4.0.11+ds4+~cs11.25.27-4
- 4.0.11+ds5+~cs11.25.27-1
- 4.0.13+ds1+~2.0.1+~cs1.4.4-1
- 4.1.3+ds1+~2.0.1+~0.15.3+~cs1.4.4-1
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-1
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-2
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-3
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-4
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-5
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-6
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-7
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-8
- 4.4.1+ds1+~3.0.5+~0.16.6+~cs1.4.4-1
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-1
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-2
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3
- 4.4.8+ds1+~3.1.0+~0.16.6+~cs1.4.4-1
- Affected ranges
- ECOSYSTEM: < 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4
Update to 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4
jupyterlab PyPI
- Versions
- 4.6.0
- 4.6.1
- Affected ranges
- ECOSYSTEM: ≥ 4.6.0, < 4.6.2
Update to 4.6.2
jupyterlab PyPI
- Versions
- 4.5.0
- 4.5.1
- 4.5.2
- 4.5.3
- 4.5.4
- 4.5.5
- 4.5.6
- 4.5.7
- 4.5.8
- 4.5.9
- Affected ranges
- ECOSYSTEM: ≥ 4.5.0, < 4.5.10
Update to 4.5.10
jupyterlab PyPI
- Versions
- 4.5.0
- 4.5.1
- 4.5.2
- 4.5.3
- 4.5.4
- 4.5.5
- 4.5.6
- 4.5.7
- 4.5.8
- 4.5.9
- 4.6.0
- 4.6.1
- Affected ranges
- ECOSYSTEM: ≥ 4.5.0, < 4.5.10 ∪ ≥ 4.6.0, < 4.6.2
Update to 4.5.10; Update to 4.6.2
jupyterlab Ubuntu:26.10
- Versions
- 4.0.11+ds1+~cs11.25.27-9
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jupyterlab Ubuntu:26.04:LTS
- Versions
- 4.0.11+ds1+~cs11.25.27-7
- 4.0.11+ds1+~cs11.25.27-8
- 4.0.11+ds1+~cs11.25.27-9
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-89vp-jrxv-24w8
- https://github.com/jupyterlab/jupyterlab/pull/19184
- https://github.com/jupyterlab/jupyterlab/pull/19185
- https://github.com/jupyterlab/jupyterlab/pull/19186
- https://github.com/jupyterlab/jupyterlab/commit/9365f020baec5221deaf11535ed554c06637c999
- https://github.com/jupyterlab/jupyterlab/commit/be9303f5bcd5308eaeae953c5a3c903046682c2c
- https://github.com/jupyterlab/jupyterlab/commit/f1beab4a2027af4719d6edc07d52d6cf5a39a432
- https://github.com/jupyterlab/jupyterlab/releases/tag/v4.5.10
- https://github.com/jupyterlab/jupyterlab/releases/tag/v4.6.2
- https://github.com/jupyterlab/jupyterlab/releases/tag/v4.7.0a1
- https://nvd.nist.gov/vuln/detail/CVE-2026-73416