p PatchFirst

CVE-2026-75899

CVE-2026-75899 · fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

fast-uri is a URI parser for Node.js. It decodes percent escapes in a hostname during parsing and then decodes the parsed hostname a second time during authority recomposition, so a single call to normalize or resolve can turn nested percent-encoded input into a different network destination such as a loopback hostname or address. For example, a doubly encoded host that spells out a loopback name decodes to that live host in one operation, which contradicts RFC 3986 section 2.4 that an implementation must not decode the same string more than once. An application that normalizes or resolves an untrusted HTTP-family URI before outbound routing, redirect validation, or a host-policy check can receive a destination different from the one the original encoded host represented, giving a server-side request forgery and host-policy bypass primitive. This is an incomplete-fix variant of CVE-2026-6322. The affected versions are 2.4.1 up to but not including 2.4.5, 3.1.2 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which normalize percent escapes once and preserve encoded percent signs. Users should upgrade to a patched version.

CVSS 7.5 · Hoch · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • fast-uri

    Softwareversionen
    • ≥ 2.4.1, < 2.4.5: Betroffen (semver)
    • 2.4.5: Nicht betroffen (semver)
    • ≥ 3.1.2, < 3.1.6: Betroffen (semver)
    • 3.1.6: Nicht betroffen (semver)
    • ≥ 4.0.0, < 4.1.3: Betroffen (semver)
    • 4.1.3: Nicht betroffen (semver)

    Auf 2.4.5 aktualisieren; Auf 3.1.6 aktualisieren; Auf 4.1.3 aktualisieren

  • node-ajv Debian:13

    Softwareversionen
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-2
    • 8.20.0~ds+~cs7.1.3-3
    • 8.20.0~ds+~cs7.1.4-1
    • 8.20.0~ds+~cs7.1.5-1
    • 8.20.0~ds+~cs7.1.6-1
    • 8.20.0~ds+~cs7.1.6-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Debian:14

    Softwareversionen
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-2
    • 8.20.0~ds+~cs7.1.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 8.20.0~ds+~cs7.1.4-1

    Auf 8.20.0~ds+~cs7.1.4-1 aktualisieren

  • fast-uri npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.4.1, < 2.4.5

    Auf 2.4.5 aktualisieren

  • fast-uri npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 3.1.2, < 3.1.6

    Auf 3.1.6 aktualisieren

  • fast-uri npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 4.0.0, < 4.1.3

    Auf 4.1.3 aktualisieren

  • node-ajv Ubuntu:18.04:LTS

    Softwareversionen
    • 5.0.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:20.04:LTS

    Softwareversionen
    • 6.10.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:22.04:LTS

    Softwareversionen
    • 6.12.6-2
    • 6.12.6-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:24.04:LTS

    Softwareversionen
    • 6.12.6-3
    • 8.12.0~ds+~2.1.1-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:26.10

    Softwareversionen
    • 8.17.1~ds+~3.0.1+~3.1.0-4build1
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:26.04:LTS

    Softwareversionen
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-4build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →