p PatchFirst

CVE-2026-77387

CVE-2026-77387 · geopy: Regular Expression Denial of Service (ReDoS) in geopy.Point

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

geopy is a geocoding library for Python. Prior to 2.5.0, geopy.Point and Point.from_string() can spend excessive CPU time due to inefficient regular-expression behavior when an application passes a long malformed coordinate string without the 256-character input limit used by the fix. Geocoder reverse methods also reach the vulnerable parsing path when called with string inputs. Repeated attacker-controlled requests can cause a denial of service, while the numeric Point constructor is unaffected. This issue is fixed in version 2.5.0.

CVSS 4.0 · Mittel · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • geopy

    Softwareversionen
    • < 2.5.0: Betroffen

    Keine Korrektur veröffentlicht

  • geopy Debian:12

    Softwareversionen
    • 2.3.0-1
    • 2.4.1-1
    • 2.4.1-2
    • 2.4.1-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • geopy Debian:13

    Softwareversionen
    • 2.4.1-1
    • 2.4.1-2
    • 2.4.1-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • geopy Debian:14

    Softwareversionen
    • 2.4.1-1
    • 2.4.1-2
    • 2.4.1-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • geopy PyPI

    Softwareversionen
    • 0.92
    • 0.93
    • 0.94
    • 0.94.1
    • 0.94.2
    • 0.95
    • 0.95.1
    • 0.96.0
    • 0.96.1
    • 0.96.2
    • 0.96.3
    • 0.97
    • 0.97.1
    • 0.98
    • 0.98.1
    • 0.98.2
    • 0.98.3
    • 0.99
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.1.1
    • 1.1.2
    • 1.1.3
    • 1.1.4
    • 1.1.5
    • 1.10.0
    • 1.11.0
    • 1.12.0
    • 1.13.0
    • 1.14.0
    • 1.15.0
    • 1.16.0
    • 1.17.0
    • 1.18.0
    • 1.18.1
    • 1.19.0
    • 1.2.0
    • 1.20.0
    • 1.21.0
    • 1.22.0
    • 1.23.0
    • 1.3.0
    • 1.4.0
    • 1.5.0
    • 1.6.0
    • 1.6.1
    • 1.7.0
    • 1.7.1
    • 1.8.0
    • 1.8.1
    • 1.9.0
    • 1.9.1
    • 2.0.0
    • 2.0.0rc1
    • 2.1.0
    • 2.2.0
    • 2.3.0
    • 2.4.0
    • 2.4.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.5.0

    Auf 2.5.0 aktualisieren

  • geopy Ubuntu:16.04:LTS

    Softwareversionen
    • 1.3.0-1build1
    • 1.11.0+ds1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • geopy Ubuntu:18.04:LTS

    Softwareversionen
    • 1.11.0+ds1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • geopy Ubuntu:20.04:LTS

    Softwareversionen
    • 1.20.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • geopy Ubuntu:22.04:LTS

    Softwareversionen
    • 2.0.0-1
    • 2.2.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • geopy Ubuntu:24.04:LTS

    Softwareversionen
    • 2.3.0-1
    • 2.3.0-1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • geopy Ubuntu:26.10

    Softwareversionen
    • 2.4.1-1
    • 2.4.1-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • geopy Ubuntu:26.04:LTS

    Softwareversionen
    • 2.4.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →