CVE-2026-77387
CVE-2026-77387 · geopy: Regular Expression Denial of Service (ReDoS) in geopy.Point
This page contains facts from public vulnerability sources. Check the original advisory before updating.
geopy is a geocoding library for Python. Prior to 2.5.0, geopy.Point and Point.from_string() can spend excessive CPU time due to inefficient regular-expression behavior when an application passes a long malformed coordinate string without the 256-character input limit used by the fix. Geocoder reverse methods also reach the vulnerable parsing path when called with string inputs. Repeated attacker-controlled requests can cause a denial of service, while the numeric Point constructor is unaffected. This issue is fixed in version 2.5.0.
CVSS 4.0 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Affected products and versions
geopy
- Versions
- < 2.5.0: Affected
No fix published
geopy Debian:12
- Versions
- 2.3.0-1
- 2.4.1-1
- 2.4.1-2
- 2.4.1-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
geopy Debian:13
- Versions
- 2.4.1-1
- 2.4.1-2
- 2.4.1-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
geopy Debian:14
- Versions
- 2.4.1-1
- 2.4.1-2
- 2.4.1-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
geopy PyPI
- Versions
- 0.92
- 0.93
- 0.94
- 0.94.1
- 0.94.2
- 0.95
- 0.95.1
- 0.96.0
- 0.96.1
- 0.96.2
- 0.96.3
- 0.97
- 0.97.1
- 0.98
- 0.98.1
- 0.98.2
- 0.98.3
- 0.99
- 1.0.0
- 1.0.1
- 1.1.0
- 1.1.1
- 1.1.2
- 1.1.3
- 1.1.4
- 1.1.5
- 1.10.0
- 1.11.0
- 1.12.0
- 1.13.0
- 1.14.0
- 1.15.0
- 1.16.0
- 1.17.0
- 1.18.0
- 1.18.1
- 1.19.0
- 1.2.0
- 1.20.0
- 1.21.0
- 1.22.0
- 1.23.0
- 1.3.0
- 1.4.0
- 1.5.0
- 1.6.0
- 1.6.1
- 1.7.0
- 1.7.1
- 1.8.0
- 1.8.1
- 1.9.0
- 1.9.1
- 2.0.0
- 2.0.0rc1
- 2.1.0
- 2.2.0
- 2.3.0
- 2.4.0
- 2.4.1
- Affected ranges
- ECOSYSTEM: < 2.5.0
Update to 2.5.0
geopy Ubuntu:16.04:LTS
- Versions
- 1.3.0-1build1
- 1.11.0+ds1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
geopy Ubuntu:18.04:LTS
- Versions
- 1.11.0+ds1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
geopy Ubuntu:20.04:LTS
- Versions
- 1.20.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
geopy Ubuntu:22.04:LTS
- Versions
- 2.0.0-1
- 2.2.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
geopy Ubuntu:24.04:LTS
- Versions
- 2.3.0-1
- 2.3.0-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
geopy Ubuntu:26.10
- Versions
- 2.4.1-1
- 2.4.1-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
geopy Ubuntu:26.04:LTS
- Versions
- 2.4.1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/geopy/geopy/security/advisories/GHSA-mhvh-fq92-pfmr
- https://github.com/geopy/geopy/issues/608
- https://github.com/geopy/geopy/pull/610
- https://github.com/geopy/geopy/commit/5d09fa843f90ec80788b61552539c9fd3ae6c528
- https://github.com/geopy/geopy/releases/tag/2.5.0
- https://nvd.nist.gov/vuln/detail/CVE-2026-77387