CVE-2026-83525
CVE-2026-83525 · Apache Kafka: Incorrect boolean operator in FetchSnapshot RPC handler allows authenticated network clients to crash the KRaft controller via a malformed request.
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Incorrect operator (CWE-480) in the FetchSnapshot RPC handler in Apache Kafka from 2.8.0 before 4.2.2, and from 4.3.0 before 4.3.2 on all platforms allows an authenticated attacker with CLUSTER_ACTION privilege to cause a denial of service (controller process termination) via a crafted FetchSnapshotRequest with an empty topics array or a topic with no partitions. Users are recommended to upgrade to version 4.2.2, 4.3.2, or 4.4.0, which fix this issue. Users on unsupported branches (4.1.x and earlier) should upgrade to 4.2.2 or later.
EPSS 0,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
apache kafka
- Softwareversionen
- ≥ 2.8.0, < 4.2.2: Betroffen (semver)
- ≥ 4.3.0, < 4.3.2: Betroffen (semver)
Auf 4.2.2 aktualisieren; Auf 4.3.2 aktualisieren
kafka Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 2.2.0u2-0ubuntu3.1
- 2.2.0u2-0ubuntu3.2
- 2.2.2u1-0ubuntu1+esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht