CVE-2026-83525
CVE-2026-83525 · Apache Kafka: Incorrect boolean operator in FetchSnapshot RPC handler allows authenticated network clients to crash the KRaft controller via a malformed request.
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Incorrect operator (CWE-480) in the FetchSnapshot RPC handler in Apache Kafka from 2.8.0 before 4.2.2, and from 4.3.0 before 4.3.2 on all platforms allows an authenticated attacker with CLUSTER_ACTION privilege to cause a denial of service (controller process termination) via a crafted FetchSnapshotRequest with an empty topics array or a topic with no partitions. Users are recommended to upgrade to version 4.2.2, 4.3.2, or 4.4.0, which fix this issue. Users on unsupported branches (4.1.x and earlier) should upgrade to 4.2.2 or later.
EPSS 0.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache kafka
- Versions
- ≥ 2.8.0, < 4.2.2: Affected (semver)
- ≥ 4.3.0, < 4.3.2: Affected (semver)
Update to 4.2.2; Update to 4.3.2
kafka Ubuntu:Pro:18.04:LTS
- Versions
- 2.2.0u2-0ubuntu3.1
- 2.2.0u2-0ubuntu3.2
- 2.2.2u1-0ubuntu1+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published