p PatchFirst

CVE-2026-84292

CVE-2026-84292 · fast-uri vulnerable to authority injection via an unvalidated port in serialize

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

fast-uri serializes the port component of a URI without validating it. When recomposing the authority, the userinfo and host components are escaped but the port is concatenated verbatim, so a port value that is not a sequence of digits can inject authority delimiters, demoting the intended host to userinfo and pointing the authority at an attacker-controlled host. Both fast-uri and Node's URL read the result back as the attacker's host with no error, so re-validating the built URI does not catch it. This affects applications that build URIs from parts and assign untrusted data to the port component through the serialize, normalize, or equal functions in their object forms. The issue affects fast-uri versions before 2.4.6, from 3.0.0 before 3.1.7, and from 4.0.0 before 4.1.4. It is fixed in 2.4.6, 3.1.7, and 4.1.4, where recomposeAuthority rejects any port that is not a digit sequence per RFC 3986.

CVSS 7.5 · Hoch · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • fast-uri

    Softwareversionen
    • ≥ 0, < 2.4.6: Betroffen (semver)
    • 2.4.6: Nicht betroffen (semver)
    • ≥ 3.0.0, < 3.1.7: Betroffen (semver)
    • 3.1.7: Nicht betroffen (semver)
    • ≥ 4.0.0, < 4.1.4: Betroffen (semver)
    • 4.1.4: Nicht betroffen (semver)

    Auf 2.4.6 aktualisieren; Auf 3.1.7 aktualisieren; Auf 4.1.4 aktualisieren

  • node-ajv Debian:13

    Softwareversionen
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-2
    • 8.20.0~ds+~cs7.1.3-3
    • 8.20.0~ds+~cs7.1.4-1
    • 8.20.0~ds+~cs7.1.5-1
    • 8.20.0~ds+~cs7.1.6-1
    • 8.20.0~ds+~cs7.1.6-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Debian:14

    Softwareversionen
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-2
    • 8.20.0~ds+~cs7.1.3-3
    • 8.20.0~ds+~cs7.1.4-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 8.20.0~ds+~cs7.1.5-1

    Auf 8.20.0~ds+~cs7.1.5-1 aktualisieren

  • fast-uri npm

    Betroffene Versionsbereiche
    • SEMVER: < 2.4.6

    Auf 2.4.6 aktualisieren

  • fast-uri npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 3.0.0, < 3.1.7

    Auf 3.1.7 aktualisieren

  • fast-uri npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 4.0.0, < 4.1.4

    Auf 4.1.4 aktualisieren

  • node-ajv Ubuntu:18.04:LTS

    Softwareversionen
    • 5.0.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:20.04:LTS

    Softwareversionen
    • 6.10.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:22.04:LTS

    Softwareversionen
    • 6.12.6-2
    • 6.12.6-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:24.04:LTS

    Softwareversionen
    • 6.12.6-3
    • 8.12.0~ds+~2.1.1-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:26.10

    Softwareversionen
    • 8.17.1~ds+~3.0.1+~3.1.0-4build1
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:26.04:LTS

    Softwareversionen
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-4build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →