CVE-2026-8597
CVE-2026-8597 · Missing integrity verification in Triton inference handler in Amazon SageMaker Python SDK
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Missing integrity verification in the Triton inference handler in Amazon SageMaker Python SDK v2 before v2.257.2 and v3 before v3.8.0 might allow a remote authenticated actor to achieve code execution in inference containers via replacement of model artifacts in S3 with a specially crafted pickle payload that is deserialized without verification. This issue requires a remote authenticated actor with S3 write access to the model artifact path. To remediate this issue, we recommend upgrading to Amazon SageMaker Python SDK v2.257.2 or v3.8.0 and rebuild any Triton models previously created with ModelBuilder using the updated SDK.
CVSS 6.4 · Mittel · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
amazon sagemaker python sdk
- Softwareversionen
- ≥ 2.199.0, ≤ 2.257.1: Betroffen (custom)
- ≥ 3.0.0, ≤ 3.7.1: Betroffen (custom)
Keine Korrektur veröffentlicht
sagemaker PyPI
- Softwareversionen
- 2.199.0
- 2.200.0
- 2.200.1
- 2.201.0
- 2.202.0
- 2.202.1
- 2.203.0
- 2.203.1
- 2.204.0
- 2.205.0
- 2.206.0
- 2.207.0
- 2.207.1
- 2.208.0
- 2.209.0
- 2.210.0
- 2.211.0
- 2.212.0
- 2.213.0
- 2.214.0
- 2.214.1
- 2.214.2
- 2.214.3
- 2.215.0
- 2.216.0
- 2.216.1
- 2.217.0
- 2.218.0
- 2.218.1
- 2.219.0
- 2.220.0
- 2.221.0
- 2.221.1
- 2.222.0
- 2.222.1
- 2.223.0
- 2.224.0
- 2.224.1
- 2.224.2
- 2.224.3
- 2.224.4
- 2.225.0
- 2.226.0
- 2.226.1
- 2.227.0
- 2.228.0
- 2.229.0
- 2.230.0
- 2.231.0
- 2.232.0
- 2.232.1
- 2.232.2
- 2.232.3
- 2.233.0
- 2.234.0
- 2.235.0
- 2.235.1
- 2.235.2
- 2.236.0
- 2.237.0
- 2.237.1
- 2.237.3
- 2.238.0
- 2.239.0
- 2.239.1
- 2.239.2
- 2.239.3
- 2.240.0
- 2.241.0
- 2.242.0
- 2.243.0
- 2.243.1
- 2.243.2
- 2.243.3
- 2.243.4
- 2.244.0
- 2.244.1
- 2.244.2
- 2.245.0
- 2.246.0
- 2.247.0
- 2.247.1
- 2.248.0
- 2.248.1
- 2.248.2
- 2.249.0
- 2.250.0
- 2.251.0
- 2.251.1
- 2.251.2.dev0
- 2.252.0
- 2.253.0
- 2.253.1
- 2.254.0
- 2.254.1
- 2.254.2.dev0
- 2.255.0
- 2.256.0
- 2.256.1
- 2.257.0
- 2.257.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.199.0, < 2.257.2
Auf 2.257.2 aktualisieren
sagemaker PyPI
- Softwareversionen
- 3.0
- 3.0.1
- 3.1.0
- 3.1.1
- 3.2.0
- 3.3.0
- 3.3.1
- 3.4.0
- 3.4.1
- 3.5.0
- 3.6.0
- 3.7.0
- 3.7.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 3.0.0, < 3.8.0
Auf 3.8.0 aktualisieren
sagemaker PyPI
- Softwareversionen
- 2.199.0
- 2.200.0
- 2.200.1
- 2.201.0
- 2.202.0
- 2.202.1
- 2.203.0
- 2.203.1
- 2.204.0
- 2.205.0
- 2.206.0
- 2.207.0
- 2.207.1
- 2.208.0
- 2.209.0
- 2.210.0
- 2.211.0
- 2.212.0
- 2.213.0
- 2.214.0
- 2.214.1
- 2.214.2
- 2.214.3
- 2.215.0
- 2.216.0
- 2.216.1
- 2.217.0
- 2.218.0
- 2.218.1
- 2.219.0
- 2.220.0
- 2.221.0
- 2.221.1
- 2.222.0
- 2.222.1
- 2.223.0
- 2.224.0
- 2.224.1
- 2.224.2
- 2.224.3
- 2.224.4
- 2.225.0
- 2.226.0
- 2.226.1
- 2.227.0
- 2.228.0
- 2.229.0
- 2.230.0
- 2.231.0
- 2.232.0
- 2.232.1
- 2.232.2
- 2.232.3
- 2.233.0
- 2.234.0
- 2.235.0
- 2.235.1
- 2.235.2
- 2.236.0
- 2.237.0
- 2.237.1
- 2.237.3
- 2.238.0
- 2.239.0
- 2.239.1
- 2.239.2
- 2.239.3
- 2.240.0
- 2.241.0
- 2.242.0
- 2.243.0
- 2.243.1
- 2.243.2
- 2.243.3
- 2.243.4
- 2.244.0
- 2.244.1
- 2.244.2
- 2.245.0
- 2.246.0
- 2.247.0
- 2.247.1
- 2.248.0
- 2.248.1
- 2.248.2
- 2.249.0
- 2.250.0
- 2.251.0
- 2.251.1
- 2.251.2.dev0
- 2.252.0
- 2.253.0
- 2.253.1
- 2.254.0
- 2.254.1
- 2.254.2.dev0
- 2.255.0
- 2.256.0
- 2.256.1
- 2.257.0
- 2.257.1
- 3.0
- 3.0.1
- 3.1.0
- 3.1.1
- 3.2.0
- 3.3.0
- 3.3.1
- 3.4.0
- 3.4.1
- 3.5.0
- 3.6.0
- 3.7.0
- 3.7.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.199.0, < 2.257.2 ∪ ≥ 3.0.0, < 3.8.0
Auf 2.257.2 aktualisieren; Auf 3.8.0 aktualisieren
Originalquellen
- https://github.com/aws/sagemaker-python-sdk/releases/tag/v2.257.2
- https://github.com/aws/sagemaker-python-sdk/releases/tag/v3.8.0
- https://aws.amazon.com/security/security-bulletins/2026-031-aws/
- https://github.com/aws/sagemaker-python-sdk/security/advisories/GHSA-rq6v-x3j8-7qgf
- https://nvd.nist.gov/vuln/detail/CVE-2026-8597