p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in sagemaker

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für sagemaker: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 8

  1. CVE-2026-8597

    Mittel · CVSS 6.4EPSS 0,51%Korrektur verfügbar

    Missing integrity verification in Triton inference handler in Amazon SageMaker Python SDK

    Missing integrity verification in the Triton inference handler in Amazon SageMaker Python SDK v2 before v2.257.2 and v3 before v3.8.0 might allow a remote authenticated actor to achieve code execution in inference containers via replacement of model artifacts in S3 with a specially crafted pickle payload that is deserialized without verification. This issue requires a remote authenticated actor with S3 write access to the model artifact path. To remediate this issue, we recommend upgrading to Amazon SageMaker Python SDK v2.257.2 or v3.8.0 and rebuild any Triton models previously created with ModelBuilder using the updated SDK.

    • Auf 2.257.2 aktualisieren
    • Auf 3.8.0 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2026-8596

    Hoch · CVSS 8.5EPSS 0,61%Korrektur verfügbar

    Cleartext storage of HMAC signing key in Amazon SageMaker Python SDK ModelBuilder/Serve path

    Cleartext storage of sensitive information in the ModelBuilder/Serve component in Amazon SageMaker Python SDK before v2.257.2 and v3 before v3.8.0 might allow a remote authenticated actor to extract the HMAC signing key from SageMaker API responses and forge valid integrity signatures for specially crafted model artifacts, achieving code execution in inference containers. This issue requires a remote authenticated actor with permissions to call SageMaker describe APIs and S3 write access to the model artifact path. To remediate this issue, we recommend upgrading to Amazon SageMaker Python SDK v2.257.2 or v3.8.0 and rebuild any models previ

    • Auf 2.257.2 aktualisieren
    • Auf 3.8.0 aktualisieren
    Veröffentlicht Aktualisiert
  3. GHSA-5r2p-pjr8-7fh7

    Hoch · CVSS 8.4Korrektur verfügbar

    SageMaker Python SDK replaced eval() with safe parser in JumpStart search functionality

    ## Summary This advisory addresses the use of the search_hub() function within the SageMaker Python SDK's JumpStart search functionality. An actor with the ability to control query parameters passed to the search_hub() function could potentially provide malformed input that causes the eval() function to execute arbitrary commands, access sensitive data, or compromise the execution environment. A defense-in-depth enhancement has been implemented to replace code evaluation with safe string operations when processing search query parameters. This enhancement removes the use of eval() from the execution path, replacing it with a safe recursive

    • Auf 3.4.0 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2026-1778

    Hoch · CVSS 8.2EPSS 0,26%Korrektur verfügbar

    TLS disabled by default in select aws/sagemaker-python-sdk configurations

    Amazon SageMaker Python SDK before v3.1.1 or v2.256.0 disables TLS certificate verification for HTTPS connections made by the service when a Triton Python model is imported, incorrectly allowing for requests with invalid and self-signed certificates to succeed.

    • Auf 2.256.0 aktualisieren
    • Auf 3.1.1 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2026-1777

    Hoch · CVSS 8.5EPSS 0,51%Korrektur verfügbar

    Cleartext transmission of sensitive materials in aws/sagemaker-python-sdk

    The Amazon SageMaker Python SDK before v3.2.0 and v2.256.0 includes the ModelBuilder HMAC signing key in the cleartext response elements of the DescribeTrainingJob function. A third party with permissions to both call this API and permissions to modify objects in the Training Jobs S3 output location may have the ability to upload arbitrary artifacts which are executed the next time the Training Job is invoked.

    • Auf 2.256.0 aktualisieren
    • Auf 3.2.0 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2025-0508

    Mittel · CVSS 5.9EPSS 0,27%Korrektur verfügbar

    MD5 Hash Collision in SageMaker Workflow in aws/sagemaker-python-sdk

    A vulnerability in the SageMaker Workflow component of aws/sagemaker-python-sdk allows for the possibility of MD5 hash collisions in all versions. This can lead to workflows being inadvertently replaced due to the reuse of results from different configurations that produce the same MD5 hash. This issue can cause integrity problems within the pipeline, potentially leading to erroneous processing outcomes.

    • Auf 2.237.3 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2024-34072

    Hoch · CVSS 7.8EPSS 0,41%Korrektur verfügbar

    Deserialization of Untrusted Data in sagemaker-python-sdk

    sagemaker-python-sdk is a library for training and deploying machine learning models on Amazon SageMaker. The sagemaker.base_deserializers.NumpyDeserializer module before v2.218.0 allows potentially unsafe deserialization when untrusted data is passed as pickled object arrays. This consequently may allow an unprivileged third party to cause remote code execution, denial of service, affecting both confidentiality and integrity. Users are advised to upgrade to version 2.218.0. Users unable to upgrade should not pass pickled numpy object arrays which originated from an untrusted source, or that could have been tampered with. Only pass pickled nu

    • Auf 2.218.0 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2024-34073

    Hoch · CVSS 7.8EPSS 1,15%Korrektur verfügbar

    Command Injection in sagemaker-python-sdk

    sagemaker-python-sdk is a library for training and deploying machine learning models on Amazon SageMaker. In affected versions the capture_dependencies function in `sagemaker.serve.save_retrive.version_1_0_0.save.utils` module allows for potentially unsafe Operating System (OS) Command Injection if inappropriate command is passed as the “requirements_path” parameter. This consequently may allow an unprivileged third party to cause remote code execution, denial of service, affecting both confidentiality and integrity. This issue has been addressed in version 2.214.3. Users are advised to upgrade. Users unable to upgrade should not override the

    • Auf 2.214.3 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →