CVE-2026-87776
CVE-2026-87776 · compression vulnerable to Denial of Service via memory leak on premature response close
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
compression is a Node.js and Express compression middleware. In versions before 1.8.2, when a client aborts the connection while a compressed response is still being sent, the zlib stream created to compress that response is never destroyed, so each aborted compressed response leaks its native zlib memory. A remote unauthenticated attacker can repeatedly open requests and disconnect early, exhausting the available memory and crashing the server. All applications using compression are affected. The issue is fixed in compression 1.8.2, and users should upgrade to 1.8.2 or later.
CVSS 7.5 · Hoch · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
compression
- Softwareversionen
- ≥ 0, < 1.8.2: Betroffen (semver)
- 1.8.2: Nicht betroffen (semver)
Auf 1.8.2 aktualisieren
node-compression Debian:12
- Softwareversionen
- 1.7.4-3
- 1.8.1-1
- 1.8.2+~1.8.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-compression Debian:13
- Softwareversionen
- 1.7.4-3
- 1.8.1-1
- 1.8.2+~1.8.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-compression Debian:14
- Softwareversionen
- 1.7.4-3
- 1.8.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.8.2+~1.8.1-1
Auf 1.8.2+~1.8.1-1 aktualisieren
compression npm
- Betroffene Versionsbereiche
- SEMVER: < 1.8.2
Auf 1.8.2 aktualisieren
node-compression Ubuntu:16.04:LTS
- Softwareversionen
- 1.1.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-compression Ubuntu:18.04:LTS
- Softwareversionen
- 1.1.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-compression Ubuntu:20.04:LTS
- Softwareversionen
- 1.7.4-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-compression Ubuntu:22.04:LTS
- Softwareversionen
- 1.7.4-2
- 1.7.4-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-compression Ubuntu:24.04:LTS
- Softwareversionen
- 1.7.4-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-compression Ubuntu:26.10
- Softwareversionen
- 1.7.4-3
- 1.8.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-compression Ubuntu:26.04:LTS
- Softwareversionen
- 1.7.4-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht