p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in node-compression

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für node-compression: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücke: 1

  1. CVE-2026-87776

    Hoch · CVSS 7.5EPSS 0,48%Korrektur verfügbar

    compression vulnerable to Denial of Service via memory leak on premature response close

    compression is a Node.js and Express compression middleware. In versions before 1.8.2, when a client aborts the connection while a compressed response is still being sent, the zlib stream created to compress that response is never destroyed, so each aborted compressed response leaks its native zlib memory. A remote unauthenticated attacker can repeatedly open requests and disconnect early, exhausting the available memory and crashing the server. All applications using compression are affected. The issue is fixed in compression 1.8.2, and users should upgrade to 1.8.2 or later.

    • Auf 1.8.2+~1.8.1-1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →