p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in rails · Seite 3

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für rails: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 114

  1. CVE-2021-22880

    Hoch · CVSS 7.5EPSS 4,43%Öffentlicher ExploitKorrektur verfügbar

    CVE-2021-22880

    The PostgreSQL adapter in Active Record before 6.1.2.1, 6.0.3.5, 5.2.4.5 suffers from a regular expression denial of service (REDoS) vulnerability. Carefully crafted input can cause the input validation in the `money` type of the PostgreSQL adapter in Active Record to spend too much time in a regular expression, resulting in the potential for a DoS attack. This only impacts Rails applications that are using PostgreSQL along with money type columns that take user input.

    • Auf 2:6.0.3.5+dfsg-1 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2020-8264

    Mittel · CVSS 6.1EPSS 66,99%Korrektur verfügbar

    CVE-2020-8264

    In actionpack gem >= 6.0.0, a possible XSS vulnerability exists when an application is running in development mode allowing an attacker to send or embed (in another page) a specially crafted URL which can allow the attacker to execute JavaScript in the context of the local application. This vulnerability is in the Actionable Exceptions middleware.

    • Auf 2:6.0.3.4+dfsg-1 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2020-15169

    Mittel · CVSS 5.4EPSS 2,37%Korrektur verfügbar

    XSS in Action View

    In Action View before versions 5.2.4.4 and 6.0.3.3 there is a potential Cross-Site Scripting (XSS) vulnerability in Action View's translation helpers. Views that allow the user to control the default (not found) value of the `t` and `translate` helpers could be susceptible to XSS attacks. When an HTML-unsafe string is passed as the default for a missing translation key named html or ending in _html, the default string is incorrectly marked as HTML-safe and not escaped. This is patched in versions 6.0.3.3 and 5.2.4.4. A workaround without upgrading is proposed in the source advisory.

    • Auf 2:6.0.3.3+dfsg-1 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2020-8162

    Hoch · CVSS 7.5EPSS 3,03%Korrektur verfügbar

    CVE-2020-8162

    A client side enforcement of server side security vulnerability exists in rails < 5.2.4.2 and rails < 6.0.3.1 ActiveStorage's S3 adapter that allows the Content-Length of a direct file upload to be modified by an end user bypassing upload limits.

    • Auf 2:5.2.4.3+dfsg-1 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2020-5267

    Mittel · CVSS 4EPSS 1,52%Korrektur verfügbar

    Possible XSS vulnerability in ActionView

    In ActionView before versions 6.0.2.2 and 5.2.4.2, there is a possible XSS vulnerability in ActionView's JavaScript literal escape helpers. Views that use the `j` or `escape_javascript` methods may be susceptible to XSS attacks. The issue is fixed in versions 6.0.2.2 and 5.2.4.2.

    • Auf 2:5.2.4.1+dfsg-2 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2019-5420

    Kritisch · CVSS 9.8EPSS 89,33%Öffentlicher ExploitKorrektur verfügbar

    CVE-2019-5420

    A remote code execution vulnerability in development mode Rails <5.2.2.1, <6.0.0.beta3 can allow an attacker to guess the automatically generated development mode secret token. This secret token can be used in combination with other Rails internals to escalate to a remote code execution exploit.

    • Auf 2:5.2.2.1+dfsg-1 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2019-5418

    Hoch · CVSS 7.5EPSS 98,51%Im KEV-KatalogÖffentlicher ExploitKorrektur verfügbar

    CVE-2019-5418

    There is a File Content Disclosure vulnerability in Action View <5.2.2.1, <5.1.6.2, <5.0.7.2, <4.2.11.1 and v3 where specially crafted accept headers can cause contents of arbitrary files on the target system's filesystem to be exposed.

    • Auf 2:5.2.2.1+dfsg-1 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2018-16477

    Mittel · CVSS 6.5EPSS 1,31%Korrektur verfügbar

    CVE-2018-16477

    A bypass vulnerability in Active Storage >= 5.2.0 for Google Cloud Storage and Disk services allow an attacker to modify the `content-disposition` and `content-type` parameters which can be used in with HTML files and have them executed inline. Additionally, if combined with other techniques such as cookie bombing and specially crafted AppCache manifests, an attacker can gain access to private signed URLs within a specific storage path. This vulnerability has been fixed in version 5.2.1.1.

    • Auf 2:5.2.2+dfsg-1 aktualisieren
    Veröffentlicht Aktualisiert
  9. CVE-2018-16476

    Hoch · CVSS 7.5EPSS 2,86%Korrektur verfügbar

    CVE-2018-16476

    A Broken Access Control vulnerability in Active Job versions >= 4.2.0 allows an attacker to craft user input which can cause Active Job to deserialize it using GlobalId and give them access to information that they should not have. This vulnerability has been fixed in versions 4.2.11, 5.0.7.1, 5.1.6.1, and 5.2.1.1.

    • Auf 2:5.2.2+dfsg-1 aktualisieren
    Veröffentlicht Aktualisiert
  10. CVE-2017-17920

    Hoch · CVSS 8.1EPSS 1,51%Keine Korrektur veröffentlicht

    CVE-2017-17920

    SQL injection vulnerability in the 'reorder' method in Ruby on Rails 5.1.4 and earlier allows remote attackers to execute arbitrary SQL commands via the 'name' parameter. NOTE: The vendor disputes this issue because the documentation states that this method is not intended for use with untrusted input

    Veröffentlicht Aktualisiert
  11. CVE-2017-17919

    Hoch · CVSS 8.1EPSS 1,51%Keine Korrektur veröffentlicht

    CVE-2017-17919

    SQL injection vulnerability in the 'order' method in Ruby on Rails 5.1.4 and earlier allows remote attackers to execute arbitrary SQL commands via the 'id desc' parameter. NOTE: The vendor disputes this issue because the documentation states that this method is not intended for use with untrusted input

    Veröffentlicht Aktualisiert
  12. CVE-2017-17917

    Hoch · CVSS 8.1EPSS 2,28%Keine Korrektur veröffentlicht

    CVE-2017-17917

    SQL injection vulnerability in the 'where' method in Ruby on Rails 5.1.4 and earlier allows remote attackers to execute arbitrary SQL commands via the 'id' parameter. NOTE: The vendor disputes this issue because the documentation states that this method is not intended for use with untrusted input

    Veröffentlicht Aktualisiert
  13. CVE-2017-17916

    Hoch · CVSS 8.1EPSS 1,54%Keine Korrektur veröffentlicht

    CVE-2017-17916

    SQL injection vulnerability in the 'find_by' method in Ruby on Rails 5.1.4 and earlier allows remote attackers to execute arbitrary SQL commands via the 'name' parameter. NOTE: The vendor disputes this issue because the documentation states that this method is not intended for use with untrusted input

    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →