p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in libphp-adodb

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für libphp-adodb: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 11

  1. CVE-2025-54119

    Kritisch · CVSS 10EPSS 0,53%Korrektur verfügbar

    ADOdb's sqlite3 driver allows SQL injection

    ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. In versions 5.22.9 and below, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a sqlite3 database and calls the metaColumns(), metaForeignKeys() or metaIndexes() methods with a crafted table name. This is fixed in version 5.22.10. To workaround this issue, only pass controlled data to metaColumns(), metaForeignKeys() and metaIndexes() method's $table parameter.

    • Auf 5.22.9-0.1+deb13u1 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2025-46337

    Kritisch · CVSS 10EPSS 0,74%Korrektur verfügbar

    SQL injection in ADOdb PostgreSQL driver pg_insert_id() method

    ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. Prior to version 5.22.9, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a PostgreSQL database and calls pg_insert_id() with user-supplied data. This issue has been patched in version 5.22.9.

    • Auf 5.22.9-0.1 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2006-4976

    Nicht bewertetEPSS 1,49%Keine Korrektur veröffentlicht

    CVE-2006-4976

    The Date Library in John Lim ADOdb Library for PHP allows remote attackers to obtain sensitive information via a direct request for (1) server.php, (2) adodb-errorpear.inc.php, (3) adodb-iterator.inc.php, (4) adodb-pear.inc.php, (5) adodb-perf.inc.php, (6) adodb-xmlschema.inc.php, and (7) adodb.inc.php; files in datadict including (8) datadict-access.inc.php, (9) datadict-db2.inc.php, (10) datadict-generic.inc.php, (11) datadict-ibase.inc.php, (12) datadict-informix.inc.php, (13) datadict-mssql.inc.php, (14) datadict-mysql.inc.php, (15) datadict-oci8.inc.php, (16) datadict-postgres.inc.php, and (17) datadict-sybase.inc.php; files in drivers/

    Veröffentlicht Aktualisiert
  4. CVE-2006-0806

    Nicht bewertetEPSS 6,01%Öffentlicher ExploitKorrektur verfügbar

    CVE-2006-0806

    Multiple cross-site scripting (XSS) vulnerabilities in ADOdb 4.71, as used in multiple packages such as phpESP, allow remote attackers to inject arbitrary web script or HTML via (1) the next_page parameter in adodb-pager.inc.php and (2) other unspecified vectors related to PHP_SELF.

    • Auf 4.72-0.1 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2006-0147

    Nicht bewertetEPSS 13,06%Öffentlicher ExploitKorrektur verfügbar

    CVE-2006-0147

    Dynamic code evaluation vulnerability in tests/tmssql.php test script in ADOdb for PHP before 4.70, as used in multiple products including (1) Mantis, (2) PostNuke, (3) Moodle, (4) Cacti, (5) Xaraya, (6) PhpOpenChat, possibly (7) MAXdev MD-Pro, and (8) Simplog, allows remote attackers to execute arbitrary PHP functions via the do parameter, which is saved in a variable that is then executed as a function, as demonstrated using phpinfo.

    • Auf 4.72-0.1 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2006-0146

    Nicht bewertetEPSS 13,24%Öffentlicher ExploitKorrektur verfügbar

    CVE-2006-0146

    The server.php test script in ADOdb for PHP before 4.70, as used in multiple products including (1) Mantis, (2) PostNuke, (3) Moodle, (4) Cacti, (5) Xaraya, (6) PHPOpenChat, (7) MAXdev MD-Pro, and (8) MediaBeez, when the MySQL root password is empty, allows remote attackers to execute arbitrary SQL commands via the sql parameter.

    • Auf 4.72-0.1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →