p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in poco

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für poco: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 7

  1. CVE-2025-45766

    Hoch · CVSS 7EPSS 0,14%Keine Korrektur veröffentlicht

    CVE-2025-45766

    poco v1.14.1-release was discovered to contain weak encryption. NOTE: this issue has been disputed on the basis that key lengths are expected to be set by an application, not by this library. This dispute is subject to review under CNA rules 4.1.4, 4.1.14, and other rules; the dispute tagging is not meant to recommend an outcome for this CVE Record.

    Veröffentlicht Aktualisiert
  2. CVE-2025-6375

    Mittel · CVSS 4.8EPSS 0,26%Korrektur verfügbar

    poco MultipartReader.cpp MultipartInputStream null pointer dereference

    A vulnerability was found in poco up to 1.14.1. It has been rated as problematic. Affected by this issue is the function MultipartInputStream of the file Net/src/MultipartReader.cpp. The manipulation leads to null pointer dereference. The attack needs to be approached locally. The exploit has been disclosed to the public and may be used. Upgrading to version 1.14.2 is able to address this issue. The patch is identified as 6f2f85913c191ab9ddfb8fae781f5d66afccf3bf. It is recommended to upgrade the affected component.

    • Auf 1.13.0-6+deb13u1 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2023-52389

    Kritisch · CVSS 9.8EPSS 0,85%Korrektur verfügbar

    CVE-2023-52389

    UTF32Encoding.cpp in POCO has a Poco::UTF32Encoding integer overflow and resultant stack buffer overflow because Poco::UTF32Encoding::convert() and Poco::UTF32::queryConvert() may return a negative integer if a UTF-32 byte sequence evaluates to a value of 0x80000000 or higher. This is fixed in 1.11.8p2, 1.12.5p2, and 1.13.0.

    • Auf 1.13.0-6 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2017-1000472

    Mittel · CVSS 6.5EPSS 1,68%Korrektur verfügbar

    CVE-2017-1000472

    The ZipCommon::isValidPath() function in Zip/src/ZipCommon.cpp in POCO C++ Libraries before 1.8 does not properly restrict the filename value in the ZIP header, which allows attackers to conduct absolute path traversal attacks during the ZIP decompression, and possibly create or overwrite arbitrary files, via a crafted ZIP file, related to a "file path injection vulnerability".

    • Auf 1.8.0-2 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2014-0350

    Nicht bewertetEPSS 1,22%Korrektur verfügbar

    CVE-2014-0350

    The Poco::Net::X509Certificate::verify method in the NetSSL library in POCO C++ Libraries before 1.4.6p4 allows man-in-the-middle attackers to spoof SSL servers via crafted DNS PTR records that are requested during comparison of a server name to a wildcard domain name in an X.509 certificate.

    • Auf 1.3.6p1-5 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2009-3560

    Nicht bewertetEPSS 24,31%Korrektur verfügbar

    CVE-2009-3560

    The big2_toUtf8 function in lib/xmltok.c in libexpat in Expat 2.0.1, as used in the XML-Twig module for Perl, allows context-dependent attackers to cause a denial of service (application crash) via an XML document with malformed UTF-8 sequences that trigger a buffer over-read, related to the doProlog function in lib/xmlparse.c, a different vulnerability than CVE-2009-2625 and CVE-2009-3720.

    • Auf 1.3.6p1-1 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2009-3720

    Nicht bewertetEPSS 27,92%Korrektur verfügbar

    CVE-2009-3720

    The updatePosition function in lib/xmltok_impl.c in libexpat in Expat 2.0.1, as used in Python, PyXML, w3c-libwww, and other software, allows context-dependent attackers to cause a denial of service (application crash) via an XML document with crafted UTF-8 sequences that trigger a buffer over-read, a different vulnerability than CVE-2009-2625.

    • Auf 1.3.6p1-1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →