p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in rustc · Seite 2

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für rustc: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 23

  1. CVE-2018-1000810

    Kritisch · CVSS 9.8EPSS 2,99%Korrektur verfügbar

    CVE-2018-1000810

    The Rust Programming Language Standard Library version 1.29.0, 1.28.0, 1.27.2, 1.27.1, 127.0, 126.2, 126.1, 126.0 contains a CWE-680: Integer Overflow to Buffer Overflow vulnerability in standard library that can result in buffer overflow. This attack appear to be exploitable via str::repeat, passed a large number, can overflow an internal buffer. This vulnerability appears to have been fixed in 1.29.1.

    • Auf 1.30.0+dfsg1-1 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2018-1000657

    Hoch · CVSS 7.8EPSS 0,54%Korrektur verfügbar

    CVE-2018-1000657

    Rust Programming Language Rust standard library version Commit bfa0e1f58acf1c28d500c34ed258f09ae021893e and later; stable release 1.3.0 and later contains a Buffer Overflow vulnerability in std::collections::vec_deque::VecDeque::reserve() function that can result in Arbitrary code execution, but no proof-of-concept exploit is currently published.. This vulnerability appears to have been fixed in after commit fdfafb510b1a38f727e920dccbeeb638d39a8e60; stable release 1.22.0 and later.

    • Auf 1.22.1+dfsg1-1 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2018-1000622

    Hoch · CVSS 7.8EPSS 1,82%Korrektur verfügbar

    CVE-2018-1000622

    The Rust Programming Language rustdoc version Between 0.8 and 1.27.0 contains a CWE-427: Uncontrolled Search Path Element vulnerability in rustdoc plugins that can result in local code execution as a different user. This attack appear to be exploitable via using the --plugin flag without the --plugin-path flag. This vulnerability appears to have been fixed in 1.27.1.

    • Auf 1.27.1+dfsg1-1~exp1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →