p PatchFirst

CVE-2018-1000810

CVE-2018-1000810

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

The Rust Programming Language Standard Library version 1.29.0, 1.28.0, 1.27.2, 1.27.1, 127.0, 126.2, 126.1, 126.0 contains a CWE-680: Integer Overflow to Buffer Overflow vulnerability in standard library that can result in buffer overflow. This attack appear to be exploitable via str::repeat, passed a large number, can overflow an internal buffer. This vulnerability appears to have been fixed in 1.29.1.

CVSS 9.8 · Kritisch · EPSS 3,0% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • n/a

    Softwareversionen
    • n/a: Betroffen

    Keine Korrektur veröffentlicht

  • rustc Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.30.0+dfsg1-1

    Auf 1.30.0+dfsg1-1 aktualisieren

  • rustc Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.30.0+dfsg1-1

    Auf 1.30.0+dfsg1-1 aktualisieren

  • rustc Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.30.0+dfsg1-1

    Auf 1.30.0+dfsg1-1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →