CVE-2018-1000622
CVE-2018-1000622
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
The Rust Programming Language rustdoc version Between 0.8 and 1.27.0 contains a CWE-427: Uncontrolled Search Path Element vulnerability in rustdoc plugins that can result in local code execution as a different user. This attack appear to be exploitable via using the --plugin flag without the --plugin-path flag. This vulnerability appears to have been fixed in 1.27.1.
CVSS 7.8 · Hoch · EPSS 1,8% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
n/a
- Softwareversionen
- n/a: Betroffen
Keine Korrektur veröffentlicht
rustc Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.27.1+dfsg1-1~exp1
Auf 1.27.1+dfsg1-1~exp1 aktualisieren
rustc Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.27.1+dfsg1-1~exp1
Auf 1.27.1+dfsg1-1~exp1 aktualisieren
rustc Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.27.1+dfsg1-1~exp1
Auf 1.27.1+dfsg1-1~exp1 aktualisieren
Originalquellen
- https://security.gentoo.org/glsa/201812-11
- https://groups.google.com/forum/#%21topic/rustlang-security-announcements/4ybxYLTtXuM
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00076.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00031.html
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000622