p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in wordpress · Seite 5

In den letzten 30 Tagen veröffentlichte Sicherheitslücke für wordpress: 1. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 353

  1. CVE-2019-8942

    Hoch · CVSS 8.8EPSS 82,74%Öffentlicher ExploitKorrektur verfügbar

    CVE-2019-8942

    WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring. An attacker with author privileges can execute arbitrary code by uploading a crafted image containing PHP code in the Exif metadata. Exploitation can leverage CVE-2019-8943.

    • Auf 5.0.1+dfsg1-1 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2018-20151

    Hoch · CVSS 7.5EPSS 5,78%Korrektur verfügbar

    CVE-2018-20151

    In WordPress before 4.9.9 and 5.x before 5.0.1, the user-activation page could be read by a search engine's web crawler if an unusual configuration were chosen. The search engine could then index and display a user's e-mail address and (rarely) the password that was generated by default.

    • Auf 5.0.1+dfsg1-1 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2018-20148

    Kritisch · CVSS 9.8EPSS 26,82%Korrektur verfügbar

    CVE-2018-20148

    In WordPress before 4.9.9 and 5.x before 5.0.1, contributors could conduct PHP object injection attacks via crafted metadata in a wp.getMediaItem XMLRPC call. This is caused by mishandling of serialized data at phar:// URLs in the wp_get_attachment_thumb_file function in wp-includes/post.php.

    • Auf 5.0.1+dfsg1-1 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2017-1000600

    Hoch · CVSS 8.8EPSS 3,8%Korrektur verfügbar

    CVE-2017-1000600

    WordPress version <4.9 contains a CWE-20 Input Validation vulnerability in thumbnail processing that can result in remote code execution. This attack appears to be exploitable via thumbnail upload by an authenticated user and may require additional plugins in order to be exploited however this has not been confirmed at this time. This issue appears to have been partially, but not completely fixed in WordPress 4.9

    • Auf 4.9.1+dfsg-1 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2018-14028

    Hoch · CVSS 7.2EPSS 15,17%Keine Korrektur veröffentlicht

    CVE-2018-14028

    In WordPress 4.9.7, plugins uploaded via the admin area are not verified as being ZIP files. This allows for PHP files to be uploaded. Once a PHP file is uploaded, the plugin extraction fails, but the PHP file remains in a predictable wp-content/uploads location, allowing for an attacker to then execute the file. This represents a security risk in limited scenarios where an attacker (who does have the required capabilities for plugin uploads) cannot simply place arbitrary PHP code into a valid plugin ZIP file and upload that plugin, because a machine's wp-content/plugins directory permissions were set up to block all new plugins.

    Veröffentlicht Aktualisiert
  6. CVE-2018-12895

    Hoch · CVSS 8.8EPSS 62,16%Öffentlicher ExploitKorrektur verfügbar

    CVE-2018-12895

    WordPress through 4.9.6 allows Author users to execute arbitrary code by leveraging directory traversal in the wp-admin/post.php thumb parameter, which is passed to the PHP unlink function and can delete the wp-config.php file. This is related to missing filename validation in the wp-includes/post.php wp_delete_attachment function. The attacker must have capabilities for files and posts that are normally available only to the Author, Editor, and Administrator roles. The attack methodology is to delete wp-config.php and then launch a new installation process to increase the attacker's privileges.

    • Auf 4.9.7+dfsg1-1 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2018-6389

    Hoch · CVSS 7.5EPSS 72,67%Öffentlicher ExploitKeine Korrektur veröffentlicht

    CVE-2018-6389

    In WordPress through 4.9.2, unauthenticated attackers can cause a denial of service (resource consumption) by using the large list of registered .js files (from wp-includes/script-loader.php) to construct a series of requests to load every file many times.

    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →