p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in pygments

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für pygments: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 5

  1. CVE-2026-4539

    Mittel · CVSS 4.8EPSS 0,16%Korrektur verfügbar

    pygments archetype.py AdlLexer redos

    A security flaw has been discovered in pygments up to 2.19.2. The impacted element is the function AdlLexer of the file pygments/lexers/archetype.py. The manipulation results in inefficient regular expression complexity. The attack is only possible with local access. The exploit has been released to the public and may be used for attacks. The project was informed of the problem early through an issue report but has not responded yet.

    • Auf 2.20.0 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2021-20270

    Hoch · CVSS 8.7EPSS 2,76%Korrektur verfügbar

    CVE-2021-20270

    An infinite loop in SMLLexer in Pygments versions 1.5 to 2.7.3 may lead to denial of service when performing syntax highlighting of a Standard ML (SML) source file, as demonstrated by input that only contains the "exception" keyword.

    • Auf 2.7.4 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2021-27291

    Hoch · CVSS 8.7EPSS 3,91%Korrektur verfügbar

    CVE-2021-27291

    In pygments 1.1+, fixed in 2.7.4, the lexers used to parse programming languages rely heavily on regular expressions. Some of the regular expressions have exponential or cubic worst-case complexity and are vulnerable to ReDoS. By crafting malicious input, an attacker can cause a denial of service.

    • Auf 2.7.4 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →