CVE-2021-27291
CVE-2021-27291
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
In pygments 1.1+, fixed in 2.7.4, the lexers used to parse programming languages rely heavily on regular expressions. Some of the regular expressions have exponential or cubic worst-case complexity and are vulnerable to ReDoS. By crafting malicious input, an attacker can cause a denial of service.
CVSS 8.7 · Hoch · EPSS 3,9% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
n/a
- Softwareversionen
- n/a: Betroffen
Keine Korrektur veröffentlicht
mediawiki Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:1.35.2-1
Auf 1:1.35.2-1 aktualisieren
mediawiki Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:1.35.2-1
Auf 1:1.35.2-1 aktualisieren
mediawiki Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:1.35.2-1
Auf 1:1.35.2-1 aktualisieren
pygments Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.7.1+dfsg-2.1
Auf 2.7.1+dfsg-2.1 aktualisieren
pygments Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.7.1+dfsg-2.1
Auf 2.7.1+dfsg-2.1 aktualisieren
pygments Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.7.1+dfsg-2.1
Auf 2.7.1+dfsg-2.1 aktualisieren
pygments PyPI
- Softwareversionen
- 1.1
- 1.1.1
- 1.2
- 1.2.1
- 1.2.2
- 1.3
- 1.3.1
- 1.4
- 1.5
- 1.6
- 1.6rc1
- 2.0
- 2.0.1
- 2.0.2
- 2.0rc1
- 2.1
- 2.1.1
- 2.1.2
- 2.1.3
- 2.2.0
- 2.3.0
- 2.3.1
- 2.4.0
- 2.4.1
- 2.4.2
- 2.5.1
- 2.5.2
- 2.6.0
- 2.6.1
- 2.7.0
- 2.7.1
- 2.7.2
- 2.7.3
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 1.1, < 2.7.4
Auf 2.7.4 aktualisieren
pygments PyPI
- Softwareversionen
- 1.1
- 1.1.1
- 1.2
- 1.2.1
- 1.2.2
- 1.3
- 1.3.1
- 1.4
- 1.5
- 1.6
- 1.6rc1
- 2.0
- 2.0.1
- 2.0.2
- 2.0rc1
- 2.1
- 2.1.1
- 2.1.2
- 2.1.3
- 2.2.0
- 2.3.0
- 2.3.1
- 2.4.0
- 2.4.1
- 2.4.2
- 2.5.1
- 2.5.2
- 2.6.0
- 2.6.1
- 2.7.0
- 2.7.1
- 2.7.2
- 2.7.3
- Betroffene Versionsbereiche
- GIT: < 2e7e8c4a7b318f4032493773732754e418279a14
- ECOSYSTEM: ≥ 1.1, < 2.7.4
Auf 2.7.4 aktualisieren
pygments Ubuntu:Pro:14.04:LTS
- Softwareversionen
- 1.6+dfsg-1
- 1.6+dfsg-1build1
- 1.6+dfsg-1ubuntu1
- 1.6+dfsg-1ubuntu1.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6+dfsg-1ubuntu1.1+esm1
Auf 1.6+dfsg-1ubuntu1.1+esm1 aktualisieren
pygments Ubuntu:16.04:LTS
- Softwareversionen
- 2.0.1+dfsg-1.1svn1
- 2.0.1+dfsg-1.1ubuntu1
- 2.1+dfsg-1
- 2.1+dfsg-1ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.1+dfsg-1ubuntu0.2
Auf 2.1+dfsg-1ubuntu0.2 aktualisieren
eric Ubuntu:16.04:LTS
- Softwareversionen
- 6.0.8-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pygments Ubuntu:18.04:LTS
- Softwareversionen
- 2.2.0+dfsg-1
- 2.2.0+dfsg-1ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.2.0+dfsg-1ubuntu0.2
Auf 2.2.0+dfsg-1ubuntu0.2 aktualisieren
eric Ubuntu:18.04:LTS
- Softwareversionen
- 17.08-1
- 17.11.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pygments Ubuntu:20.04:LTS
- Softwareversionen
- 2.3.1+dfsg-1ubuntu1
- 2.3.1+dfsg-1ubuntu2
- 2.3.1+dfsg-1ubuntu2.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.3.1+dfsg-1ubuntu2.2
Auf 2.3.1+dfsg-1ubuntu2.2 aktualisieren
eric Ubuntu:20.04:LTS
- Softwareversionen
- 19.02.1+ds1-1
- 19.8+ds1-1
- 19.12+ds1-1
- 20.1+ds1-1
- 20.2+ds1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
eric Ubuntu:22.04:LTS
- Softwareversionen
- 21.1+ds1-1
- 21.1+ds1-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
eric Ubuntu:24.04:LTS
- Softwareversionen
- 23.2+ds1-1
- 23.2+ds1-2
- 23.2+ds1-2ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
eric Ubuntu:25.10
- Softwareversionen
- 24.3+ds1-1
- 24.8+ds1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
eric Ubuntu:26.10
- Softwareversionen
- 24.8+ds1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
eric Ubuntu:26.04:LTS
- Softwareversionen
- 24.8+ds1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://gist.github.com/b-c-ds/b1a2cc0c68a35c57188575eb496de5ce
- https://github.com/pygments/pygments/commit/2e7e8c4a7b318f4032493773732754e418279a14
- https://lists.debian.org/debian-lts-announce/2021/03/msg00024.html
- https://www.debian.org/security/2021/dsa-4878
- https://www.debian.org/security/2021/dsa-4889
- https://lists.debian.org/debian-lts-announce/2021/05/msg00003.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GSJRFHALQ7E3UV4FFMFU2YQ6LUDHAI55/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WSLD67LFGXOX2K5YNESSWAS4AGZIJTUQ/
- https://lists.debian.org/debian-lts-announce/2021/05/msg00006.html
- https://nvd.nist.gov/vuln/detail/CVE-2021-27291