p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in wsgidav

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für wsgidav: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 3

  1. CVE-2026-55509

    Hoch · CVSS 8.8EPSS 0,51%Korrektur verfügbar

    WsgiDAV: Blind SQL injection in the MySQL provider

    WsgiDAV is a generic and extendable WebDAV server based on WSGI. Prior to 4.3.5, the sample MySQLBrowserProvider in wsgidav/samples/mysql_dav_provider.py concatenates the record key parsed from a request URL directly into SQL WHERE clauses. The affected _exists_record_by_primary_key, _get_field_by_primary_key, and _get_record_by_primary_key methods are part of a shipped example provider that is not enabled by default. An attacker who can access a share explicitly configured with this non-default provider can inject SQL through a normal GET request; anonymously exposed read shares permit a status-code oracle and extraction of arbitrary data re

    • Auf 4.3.5 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2026-48099

    Hoch · CVSS 7.1EPSS 0,33%Korrektur verfügbar

    WsgiDAV encoded dot segments can escape filesystem share roots

    WsgiDAV is a generic and extendable WebDAV server based on WSGI. WsgiDAV 4.3.3 and prior can allow a WebDAV request path containing an encoded parent-directory segment to escape the configured filesystem share root in a specific path layout. The issue is fixed with version 4.3.4.

    • Auf 4.3.4 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2022-41905

    Hoch · CVSS 8.2EPSS 0,37%Korrektur verfügbar

    wsgidav is vulnerable to Cross-Site Scripting (XSS) when directory browsing is enabled

    WsgiDAV is a generic and extendable WebDAV server based on WSGI. Implementations using this library with directory browsing enabled may be susceptible to Cross Site Scripting (XSS) attacks. This issue has been patched, users can upgrade to version 4.1.0. As a workaround, set `dir_browser.enable = False` in the configuration.

    • Auf 4.1.0 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →