p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de wsgidav

Vulnérabilité publiée pour wsgidav au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 3

  1. CVE-2026-55509

    Élevée · CVSS 8.8EPSS 0,51%Correctif disponible

    WsgiDAV: Blind SQL injection in the MySQL provider

    WsgiDAV is a generic and extendable WebDAV server based on WSGI. Prior to 4.3.5, the sample MySQLBrowserProvider in wsgidav/samples/mysql_dav_provider.py concatenates the record key parsed from a request URL directly into SQL WHERE clauses. The affected _exists_record_by_primary_key, _get_field_by_primary_key, and _get_record_by_primary_key methods are part of a shipped example provider that is not enabled by default. An attacker who can access a share explicitly configured with this non-default provider can inject SQL through a normal GET request; anonymously exposed read shares permit a status-code oracle and extraction of arbitrary data re

    • Mettez à jour vers 4.3.5
    Publication Mise à jour
  2. CVE-2026-48099

    Élevée · CVSS 7.1EPSS 0,33%Correctif disponible

    WsgiDAV encoded dot segments can escape filesystem share roots

    WsgiDAV is a generic and extendable WebDAV server based on WSGI. WsgiDAV 4.3.3 and prior can allow a WebDAV request path containing an encoded parent-directory segment to escape the configured filesystem share root in a specific path layout. The issue is fixed with version 4.3.4.

    • Mettez à jour vers 4.3.4
    Publication Mise à jour
  3. CVE-2022-41905

    Élevée · CVSS 8.2EPSS 0,37%Correctif disponible

    wsgidav is vulnerable to Cross-Site Scripting (XSS) when directory browsing is enabled

    WsgiDAV is a generic and extendable WebDAV server based on WSGI. Implementations using this library with directory browsing enabled may be susceptible to Cross Site Scripting (XSS) attacks. This issue has been patched, users can upgrade to version 4.1.0. As a workaround, set `dir_browser.enable = False` in the configuration.

    • Mettez à jour vers 4.1.0
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →