p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in flask

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für flask: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 2

  1. CVE-2026-27205

    Niedrig · CVSS 2.3EPSS 0,4%Keine Korrektur veröffentlicht

    Flask session does not add `Vary: Cookie` header when accessed in some ways

    Flask is a web server gateway interface (WSGI) web application framework. In versions 3.1.2 and below, when the session object is accessed, Flask should set the Vary: Cookie header., resulting in a Use of Cache Containing Sensitive Information vulnerability. The logic instructs caches not to cache the response, as it may contain information specific to a logged in user. This is handled in most cases, but some forms of access such as the Python in operator were overlooked. The severity and risk depend on the application being hosted behind a caching proxy that doesn't ignore responses with cookies, not setting a Cache-Control header to mark pa

    Veröffentlicht Aktualisiert
  2. CVE-2018-1000656

    Hoch · CVSS 8.7EPSS 3,85%Korrektur verfügbar

    CVE-2018-1000656

    The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of service. This attack appear to be exploitable via Attacker provides JSON data in incorrect encoding. This vulnerability appears to have been fixed in 0.12.3. NOTE: this may overlap CVE-2019-1010083.

    • Auf 0.10.1-2ubuntu0.1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →