CVE-2018-1000656
CVE-2018-1000656
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of service. This attack appear to be exploitable via Attacker provides JSON data in incorrect encoding. This vulnerability appears to have been fixed in 0.12.3. NOTE: this may overlap CVE-2019-1010083.
CVSS 8.7 · Hoch · EPSS 3,9% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
n/a
- Softwareversionen
- n/a: Betroffen
Keine Korrektur veröffentlicht
flask Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.0.2-1
Auf 1.0.2-1 aktualisieren
flask Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.0.2-1
Auf 1.0.2-1 aktualisieren
flask Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.0.2-1
Auf 1.0.2-1 aktualisieren
flask PyPI
- Softwareversionen
- 0.1
- 0.10
- 0.10.1
- 0.11
- 0.11.1
- 0.12
- 0.12.1
- 0.12.2
- 0.2
- 0.3
- 0.3.1
- 0.4
- 0.5
- 0.5.1
- 0.5.2
- 0.6
- 0.6.1
- 0.7
- 0.7.1
- 0.7.2
- 0.8
- 0.8.1
- 0.9
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.12.3
Auf 0.12.3 aktualisieren
flask Ubuntu:Pro:14.04:LTS
- Softwareversionen
- 0.10.1-2
- 0.10.1-2build1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.10.1-2ubuntu0.1~esm1
Auf 0.10.1-2ubuntu0.1~esm1 aktualisieren
flask Ubuntu:16.04:LTS
- Softwareversionen
- 0.10.1-2build2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.10.1-2ubuntu0.1
Auf 0.10.1-2ubuntu0.1 aktualisieren
flask Ubuntu:18.04:LTS
- Softwareversionen
- 0.12.2-2
- 0.12.2-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.12.2-3ubuntu0.1
Auf 0.12.2-3ubuntu0.1 aktualisieren