p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in ghostscript

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für ghostscript: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 94

  1. CVE-2020-27824

    Mittel · CVSS 5.5EPSS 1,61%Korrektur verfügbar

    CVE-2020-27824

    A flaw was found in OpenJPEG’s encoder in the opj_dwt_calc_explicit_stepsizes() function. This flaw allows an attacker who can supply crafted input to decomposition levels to cause a buffer overflow. The highest threat from this vulnerability is to system availability.

    • Auf 9.26~dfsg+0-0ubuntu0.16.04.14 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2020-27814

    Hoch · CVSS 7.8EPSS 2,1%Korrektur verfügbar

    CVE-2020-27814

    A heap-buffer overflow was found in the way openjpeg2 handled certain PNG format files. An attacker could use this flaw to cause an application crash or in some cases execute arbitrary code with the permission of the user running such an application.

    • Auf 9.26~dfsg+0-0ubuntu0.16.04.14 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2020-27845

    Mittel · CVSS 5.5EPSS 1,52%Korrektur verfügbar

    CVE-2020-27845

    There's a flaw in src/lib/openjp2/pi.c of openjpeg in versions prior to 2.4.0. If an attacker is able to provide untrusted input to openjpeg's conversion/encoding functionality, they could cause an out-of-bounds read. The highest impact of this flaw is to application availability.

    • Auf 9.26~dfsg+0-0ubuntu0.16.04.14 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2020-27843

    Mittel · CVSS 5.5EPSS 1,77%Korrektur verfügbar

    CVE-2020-27843

    A flaw was found in OpenJPEG in versions prior to 2.4.0. This flaw allows an attacker to provide specially crafted input to the conversion or encoding functionality, causing an out-of-bounds read. The highest threat from this vulnerability is system availability.

    • Auf 9.26~dfsg+0-0ubuntu0.16.04.14 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2020-27842

    Mittel · CVSS 5.5EPSS 1,52%Korrektur verfügbar

    CVE-2020-27842

    There's a flaw in openjpeg's t2 encoder in versions prior to 2.4.0. An attacker who is able to provide crafted input to be processed by openjpeg could cause a null pointer dereference. The highest impact of this flaw is to application availability.

    • Auf 9.26~dfsg+0-0ubuntu0.16.04.14 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2020-27841

    Mittel · CVSS 5.5EPSS 1,45%Korrektur verfügbar

    CVE-2020-27841

    There's a flaw in openjpeg in versions prior to 2.4.0 in src/lib/openjp2/pi.c. When an attacker is able to provide crafted input to be processed by the openjpeg encoder, this could cause an out-of-bounds read. The greatest impact from this flaw is to application availability.

    • Auf 9.26~dfsg+0-0ubuntu0.16.04.14 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2020-17538

    Mittel · CVSS 5.5EPSS 1,93%Korrektur verfügbar

    CVE-2020-17538

    A buffer overflow vulnerability in GetNumSameData() in contrib/lips4/gdevlips.c of Artifex Software GhostScript from v9.18 to v9.50 allows a remote attacker to cause a denial of service via a crafted PDF file. This is fixed in v9.51.

    • Auf 9.26~dfsg+0-0ubuntu0.16.04.13 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2020-16307

    Mittel · CVSS 5.5EPSS 1,77%Korrektur verfügbar

    CVE-2020-16307

    A null pointer dereference vulnerability in devices/vector/gdevtxtw.c and psi/zbfont.c of Artifex Software GhostScript v9.50 allows a remote attacker to cause a denial of service via a crafted postscript file. This is fixed in v9.51.

    • Auf 9.26~dfsg+0-0ubuntu0.16.04.13 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →