p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in gnutls28

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für gnutls28: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 14

  1. USN-4233-2

    Nicht bewertetKorrektur verfügbar

    gnutls28 update

    USN-4233-1 disabled SHA1 being used for digital signature operations in GnuTLS. In certain network environments, certificates using SHA1 may still be in use. This update adds the %VERIFY_ALLOW_BROKEN and %VERIFY_ALLOW_SIGN_WITH_SHA1 priority strings that can be used to temporarily re-enable SHA1 until certificates can be replaced with a stronger algorithm. Original advisory details: As a security improvement, this update marks SHA1 as being untrusted for digital signature operations.

    • Auf 3.4.10-4ubuntu1.7 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2018-10846

    Mittel · CVSS 5.3EPSS 0,39%Korrektur verfügbar

    CVE-2018-10846

    A cache-based side channel in GnuTLS implementation that leads to plain text recovery in cross-VM attack setting was found. An attacker could use a combination of "Just in Time" Prime+probe attack in combination with Lucky-13 attack to recover plain text using crafted packets.

    • Auf 3.4.10-4ubuntu1.5 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2018-10845

    Mittel · CVSS 5.9EPSS 3,58%Korrektur verfügbar

    CVE-2018-10845

    It was found that the GnuTLS implementation of HMAC-SHA-384 was vulnerable to a Lucky thirteen style attack. Remote attackers could use this flaw to conduct distinguishing attacks and plain text recovery attacks via statistical analysis of timing data using crafted packets.

    • Auf 3.4.10-4ubuntu1.5 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2018-10844

    Mittel · CVSS 5.9EPSS 3,58%Korrektur verfügbar

    CVE-2018-10844

    It was found that the GnuTLS implementation of HMAC-SHA-256 was vulnerable to a Lucky thirteen style attack. Remote attackers could use this flaw to conduct distinguishing attacks and plaintext-recovery attacks via statistical analysis of timing data using crafted packets.

    • Auf 3.4.10-4ubuntu1.5 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2016-8610

    Hoch · CVSS 7.5EPSS 39,66%Öffentlicher ExploitKorrektur verfügbar

    CVE-2016-8610

    A denial of service flaw was found in OpenSSL 0.9.8, 1.0.1, 1.0.2 through 1.0.2h, and 1.1.0 in the way the TLS/SSL protocol defined processing of ALERT packets during a connection handshake. A remote attacker could use this flaw to make a TLS/SSL server consume an excessive amount of CPU and fail to accept connections from other clients.

    • Auf 3.4.10-4ubuntu1.2 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2017-7869

    Hoch · CVSS 7.5EPSS 2,84%Korrektur verfügbar

    CVE-2017-7869

    GnuTLS before 2017-02-20 has an out-of-bounds write caused by an integer overflow and heap-based buffer overflow related to the cdk_pkt_read function in opencdk/read-packet.c. This issue (which is a subset of the vendor's GNUTLS-SA-2017-3 report) is fixed in 3.5.10.

    • Auf 3.4.10-4ubuntu1.3 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2017-5334

    Kritisch · CVSS 9.8EPSS 32,75%Korrektur verfügbar

    CVE-2017-5334

    Double free vulnerability in the gnutls_x509_ext_import_proxy function in GnuTLS before 3.3.26 and 3.5.x before 3.5.8 allows remote attackers to have unspecified impact via crafted policy language information in an X.509 certificate with a Proxy Certificate Information extension.

    • Auf 3.4.10-4ubuntu1.2 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2016-7444

    Hoch · CVSS 7.5EPSS 2,44%Korrektur verfügbar

    CVE-2016-7444

    The gnutls_ocsp_resp_check_crt function in lib/x509/ocsp.c in GnuTLS before 3.4.15 and 3.5.x before 3.5.4 does not verify the serial length of an OCSP response, which might allow remote attackers to bypass an intended certificate validation mechanism via vectors involving trailing bytes left by gnutls_malloc.

    • Auf 3.4.10-4ubuntu1.2 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →